29794Views40Replies

Author Options:

AAAAAAaaaaaaaaaahh!!!!! WHY WHY WHY Cant my computer see my Arduino? Answered

Going on my 2nd week...thats 14 days  of trying EVERYTHING I can find to get my Win xp pro 32bit - sp3 to see anything beyond the USBasp?   I've completely given up on trying to get the UNO direct USB hookup...I only get NEW DEVICE- USB2.0-SERIAL . Uninstalled-reinstalled- repeat with port changes and following the SAME directions posted all over the interwebs. 
My DIYduinos have UNO and 2 with Deum'nove bootloaded and blink sketch installed when I purchased them....they give the blinkin LED when powered up.

I've also had several unsuccessful attempts at the FTDI driver....the USB2.0 "official" drivers...the Arduino IDE USB driver..you name it...I probably tried it.  nothin'

I'm no baby, but, I'm seriously on the verge of frustration tears!!  apparently I'm the only one who has this issue 'cause theres nothing I can find on it...the existing instructions out there are sooo frustrating in themselves as they just plug it in and there computer sees the UNO or whatever and they just go on from there...or stop after windows sees the USBasp programmer....I have THAT but, cant get any further with it. My Uno clone has a10 pin USBasp header on it...says right on it USBasp!...When I hook it all up, I get power on the board(s) from the USBasp programmer hooked to my comp...windows sees the USBasp but nothing attached...let alone a virtual com port arrangment.

PLEASE anyone who knows what the issue might be or an educated guess is welcome too!!!  I'll send you Art!  or a 'duino with LM293D chips able to drive 2 stepper motors I've made!  if you solve it...you'll be rewarded somehow!!!

43 Replies

user
SuperTech-ITBest Answer (author)2014-03-14

The Uno itself should only appear in your device manager as a USB2.0 serial port.

That's it, nothing more.

When you run the IDE software, you simply set the board as UNO, and set the com port to whatever port the USB2.0 com port is sitting at (COM2:, Com3:, COM6:, whatever it may be). Once your IDE software is configured, after you have your code loaded, you can simply click the upload button, and the code will upload to your UNO over the serial port it made.

A USBasp will only appear in the device manager as a USBasp. Nothing more - no matter what's attached to it. It does not see or create a virtual serial port or anything like that. It is only itself, and nothing more.

If you want to use the USBasp to program your uno, again you have to set the board as an Uno, and then use CTRL-SHIFT-U to upload the code, or click File > Upload using programmer.

Select as Best AnswerUndo Best Answer

user
schel (author)SuperTech-IT2014-03-15

OK heres my device mngr. screen. So, that it shows up as USB2.0-SERIAL is what I want ,,,yes? but how do I get my comp or the IDE to see it as a COM port? I suppose thats my root question...that is if my comp only seeing "USB2.0 -serial" and not UNO-USB etc is what it should be.

-"When you run the IDE software, you simply set the board as UNO, and set
the com port to whatever port the USB2.0 com port is sitting at (COM2:,
Com3:, COM6:, whatever it may be)
"......thats one of the issues I guess...the USB is not showing up as a com port of any kind neither in Device MNGR. nor in the IDE. and stoopid ol Winxp wont seem to let me see anything outside of the icon n' win-fluff UI. I miss windows 3.1 ..hehehee..you could get in there like a VW engine and tweak whatever you needed!

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)schel2014-03-15

the USBasp doesn't show up as a com port. Ever. Period.
It also never show what's connected to it. Ever.

Your serial port - if that's your UNO that's got that port on it - then the drivers I sent should fix that.
If not, then you program your chips usinf the USBasp (blows out the bootloader, but we don't care) and you put an ICSP header on whatever project you build so that if you need to reprogram it, you just hook up the USBasp and reprogram it.
My projects all have an ICSP header on them.

Select as Best AnswerUndo Best Answer

user
DavíV (author)SuperTech-IT2015-02-27

please, help me too. I have the same problem here

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)DavíV2015-02-27

describe what you mean by "same problem". Are you connecting an Arduino or a USBASP or USBTiny or what? Include a screen shot of your device manager with the comports tab opened up. Give a COMPLETE description of the exact problem you have, as well as what you have tried to do to rectify it, and what program you are trying to access the device with, and how you configured it to see the device etc. "same problem too" simply isn't enough info for me to help you.

Select as Best AnswerUndo Best Answer

user
DavíV (author)SuperTech-IT2015-02-27

sorry man, I wasn't too precise =s
but I already solved it, some hours ago.
My problem was: In my Devide Manager, only Usb 2.0 serial was showing and I failed when I tried to install the drivers manually. But I discovered that I bought a non original Arduino. After I've installed this drivers:http://wch.cn/downloads.php?name=pro&proid=5 the COM port appeared and everything was fine.

Anyway, thanks for you attention.

Select as Best AnswerUndo Best Answer

user
GyulaM2 (author)DavíV2016-08-30

BRILL!! BIG BIG LIKE For you! thanks a lot, it's solved for me

Select as Best AnswerUndo Best Answer

user
MarrionE (author)DavíV2015-12-11

This is great, hours of searching and this post solved my issue. thanks for sharing !

Select as Best AnswerUndo Best Answer

user
psyberjock (author)DavíV2015-11-06

Thank you VERY much for this link. It solved my problem as well. Crappy chinese made clones... why on earth do they need different drivers when everything else works the same!? Still, problem solved. Thanks a ton!

Select as Best AnswerUndo Best Answer

user
Utkarsh Bajpai (author)DavíV2016-06-23
user

i am facing the same problem please can u send me driver for that thankss

Select as Best AnswerUndo Best Answer

user
schel (author)SuperTech-IT2014-03-15

Ka-chang ka-chang chang!!! Yesss!!!! You da' Man SUPER-T!! ICSP...and forget everything else...heheheee...So I took the frustrated clue and said -forget what windows is telling me...ignore the COM thing all together...I only had COM1 or COM2 to choose from and neither was it anyways....I hooked up the USBasp to my 10 to 6 pin adapter - and that to the UNO clone , uploaded the servo sweep sketch...the asp blink LEDS the UNO blinked really fast and suddenly the blinking LED (sketch) was no more....I hooked up a servo to pin 9 -+-G and check it out....sweepin' servo...oh yeah!!!

Thanks sooo much Super-T !! I'll post up some pics of what I'm doing soon!

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)schel2014-03-15

Glad I could help. Honestly, if you want your AVR to be easily ported to your finished product, ICSP is the way to go. Then you can use a USBasp, or USBTiny, or a plethora of other ICSP programmers to program it up. It's the way to go if you have a programmer. I figured you might get the idea if I showed you the one video of me programming up my boards using the ICSP. Hope to see what you're up to soon, and hope you enjoyed my little videos!

Select as Best AnswerUndo Best Answer

user
schel (author)SuperTech-IT2014-03-15

HmmmmmBells are goin' off in my head..this sounds like where I started and why I got the USBasp in the first place! I'm liking this avenue....yes! My UNO clone has an ICSP header on it!...6 pin so, I need to make a 10 pin to 6 pin adapter for the programmer oui? I actually have those schematics and 'ible. Gonna get on that tonight!

Thanks SuperT! whether or not THIS works I'd like to send ya some Art or somethin' for your time! I have prints of the "robot-girl n' Poppies" and a "shipwreck in a tree" print I believe...I think they are on my site if ya wanna pick one out, I'll send ya one! OR if ya have a good printer I'll send ya the hi-res file and you can print yer own....fo' real.

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)schel2014-03-15

https://www.youtube.com/watch?v=YnDuVS66CZg

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)schel2014-03-15

Nah, I'm good, thanks. I have my own little piece of 3D electronic art which those boards I showed you control.

here's a demo of them:
http://www.youtube.com/watch?v=Sv2l1zyNMYY

Select as Best AnswerUndo Best Answer

user
schel (author)schel2014-03-15

Oh yes, I tried the old files you posted...nothing changed. but, I'm hanging on to them 'cause they look quite useful to have JIC! I'm not trying to bootload as the chips I have are pre-bootloaded....I need to be able to program...without pulling the chips out everytime I need to adjust a sketch...Can I do this with the USBasp programmer I have without losing the bootloader everytime?...or do I even need to worry about the bootloader once I upload a sketch?

Select as Best AnswerUndo Best Answer

user

I'd like to point out by the way the if you upload your code using the USBasp programmer, you WILL blow out your bootloader when you do it - so don't upload code to the arduino with the USBasp and then expect to be able to propgram it again using the Uno itself. To put the bootloader back in, you need to connect the USBasp, and click TOOLS > PROGRAMMER and select the USBasp as your programmer, and then click TOOLS > BURN BOOTLOADER.

Select as Best AnswerUndo Best Answer

user
schel (author)SuperTech-IT2014-03-14

Whoa! really? well thats dern useful info Thanks! Now whaddam I gonna do? I seriously thought I had done my homework before jumpin' into Arduino addictions. Your previous reply is mostly on course of where I'm at presently...My comp sees "USB2.0 -serial" when hooked up to the UNO-clones but wants a driver...I have sp3 installed which is supposed to have 2.o+ usb drivers...and I do see a " enhanced" next to a usb hub in Device mngr. so it's in there. In the A-IDE I show: com1 -com2 -printer-

no uno nor others. in Device manager the USB2.0 shows up on its own...not with com ports nor the USB hub...thats where I'm baffled!

Back to the USBASP thing....theres no way to keep the bootloader on the IC using asp? my DIY boards were gonna depend on NOT having to buy USB-TTL -FTDI thingys. Thanks SuperT. guess I need a different route.

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)schel2014-03-14

TOOLS > BOARD > Arduino uno
TOOLS > SERIAL PORT > whatever port the USB2.0 serial is....

I think I hear ya about the usb2.0 thing though if it has a "!" beside it...
If that's the case, here - try these.

Select as Best AnswerUndo Best Answer

user

At least that's what I recall from when I last tried to install it on XP....feel free to correct me if I am wrong.

Select as Best AnswerUndo Best Answer

user

+1

Squares with my experience too

Select as Best AnswerUndo Best Answer

user
Libahunt (author)2014-03-13

Could you explain what you mean by "DIYduinos that you purchased"?

Do I undestand right that plugging an arduino board in shows up as some kind of device, but not as Arduino for the IDE? And USBasp programmer also shows up, but sees no AVR controller attached to it?
My observations if I understood correct so far - the FTDI and computer talk to each other, also the computer talks to USBasp programmer, I think the problem is not in the computer and it's drivers but further down. Could it be possible, that all of your Arduinos (three pieces, right?) are faulty in a way that prevents their FTDI chip AND their ISP headers from talking to the ATmega controller?
FTDI uses TX, RX (pins 0, 1), gnd, +5V and reset, ISP header is connected to MISO, MOSI, SCK (pins 11, 12, 13), gnd, +5V and reset. If lights come up when either one of these cables is connected then gnd and +5 are okay. That leaves only reset as common suspect for both.

If you hold down reset button the blink sketch should not run until you release the button. Does the button work as expected? Find the reset pin in ISP header and ground that - does it stop the blinking?

Hope it helps you a bit further or at least clear your head and tackle the problem again with fresh eyes.

Select as Best AnswerUndo Best Answer

user
schel (author)Libahunt2014-03-15

Thanks Libahunt, you definately helped define a lot of the issue and cleared up some mysteries on which way to go with this. Cheers!

Select as Best AnswerUndo Best Answer

user
schel (author)Libahunt2014-03-14

Arduino type kits...like the Anarduino and the DIYduino. But I also bought 2 UNO clones that has a ten male pin out labeled USBASP and a 6 pin icsp header

Yep the blinking LED (not the power ind.) stops when Reset is held down and blinks quickly then to the regular blink when released.

I have the layouts for the mentioned pins. cept I think you have the right idea of where the issue is....Im gonna try that. Thanks!!

Select as Best AnswerUndo Best Answer

user
schel (author)schel2014-03-14

OK I found some info..but first ...Thank You people for sharing your knowledge and time to read / answer...Much Thanks!!

So I think I need this for my DIY and Anarduino to program without losing the bootloaders Please tell me if this is incorrect or a bad road to take!

FT23RL FTDI USB to TTL Serial adapter module

Select as Best AnswerUndo Best Answer

user
SuperTech-IT (author)schel2014-03-14

If your USBasp works, you don't need the bootloader. Ever.

You also don't have to worry about your bootloader not working because you changed the speed of the crystal.

Also, a USBasp is only about 3 bucks with free delivery off Ebay.

If your USBasp is asking for a driver, and you don't have one, then try this.

Select as Best AnswerUndo Best Answer

user

You'll need to rename the gibberish filename you download to the filename above because when Instructables stores a file, it puts the gibberish names to them - I don't know why. All I know is "if it's not a bug, we don't intend to fix it" has always been the attitude here.

Select as Best AnswerUndo Best Answer

user
Ruben GeradM (author)2015-07-27

I had the same problem both with mega and nano, this chinese driver fixed the problem.

http://www.wch.cn/download/CH341SER_ZIP.html

Further details available on: http://forum.arduino.cc/index.php?topic=281746.0

Select as Best AnswerUndo Best Answer

user
LeightonG1 (author)Ruben GeradM2016-08-14

Thank you so much, after hours of searching I finally found the solution. After my original Arduino died I decided to purchase a clone and I couldn't understand why I couldn't write my old code to the Arduino. Thanks you sir!

Select as Best AnswerUndo Best Answer

user
bgm2 (author)2016-03-23

helo please a little help my arduino uno appear like an Atml usb devices not as a port what should i do ?? thanks

Select as Best AnswerUndo Best Answer

user
mhassan22 (author)2016-02-14

FORMAT YOUR PC AND INSTALL EVERYTHING FRESH

Select as Best AnswerUndo Best Answer

user
RavinduP1 (author)2015-10-30
user
johnfixesstuff (author)2015-06-03

I ran into this same issue and was able to manually load the drivers and have written up all the steps for a Windows 7 machine, which should go real similarly for your XP machine: http://www.johnfixesstuff.com/2015/06/how-to-install-arduino-usb-drivers-in-windows-7.html

Select as Best AnswerUndo Best Answer

user
OlleB (author)2015-01-24



I had a similar problem, found solution for mac, there might be something for you here https://www.google.se/webhp?sourceid=chrome-instan...

This solved things for me: http://kiguino.moos.io/2014/12/31/how-to-use-ardui...

Select as Best AnswerUndo Best Answer

user
OlleB (author)2015-01-24



I had a similar problem, found solution for mac, there might be something for you here https://www.google.se/webhp?sourceid=chrome-instan...

This solved things for me: http://kiguino.moos.io/2014/12/31/how-to-use-ardui...

Select as Best AnswerUndo Best Answer

user
KlausL1 (author)2014-08-28

Another very simple solution (after a lot of search in the internet):

Your arduino clone might use a CH340/CH341 USB to serial communication chip. That is the component which your computer needs the driver for. Just use that CH341 driver (http://wch-ic.com/download/list.asp?id=127) instead of the driver that comes with the arduino software.

That worked for my 3€ china clone like a charm.

Select as Best AnswerUndo Best Answer

user
dkosasih (author)2014-05-19

This thread will probably shed some lights for me.

I have the same situation using osx 10.7 and it has been days I tried to figure out why I could not find the serial port related to my UNO. So I decided to use USBasp. My question for this is, how do I debug using this? As I cannot use serial monitor to monitor the serial activity. Please help...

Select as Best AnswerUndo Best Answer

user
Josehf Murchison (author)2014-03-13

When you get the new device message it should say what port it is on, go to devices and printers click on brows for driver and direct it to sketch.

You may need to do this every time you change the USB port.

Select as Best AnswerUndo Best Answer