35394Views12Replies

Author Options:

Arduino Mega 2560 timeout? Answered

I have tried uploading the simple "Blink" sketch onto a 5v Mega Pro from Spakrfun using their 5v FTDI programmer. Despite my best efforts I have kept getting this error...

Binary sketch size: 1,632 bytes (of a 258,048 byte maximum)
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

I have know I am using the correct COM port and I have the right board selected. I have tried to re-install the driver but to no avail. Nothing I have found online has worked.

12 Replies

user
le_chakBest Answer (author)2013-10-27

Hi. I had same issue and solve it. I go to hardvare manager in Windows. Find device named USB Serial Converter under USB Controllers group. Right click and Select Update Drivers. Then MANUALY select FTDI driver located in arduino folder (\arduino-1.0.5\drivers\FTDI USB Drivers) and install it. Allow window to use this driver when he ask for it. After this all work fine.
Hope this will help.

Select as Best AnswerUndo Best Answer

user
ketank (author)le_chak2014-08-24

Hey, What do u select as programmer in tools menu when trying to upload sketch via FTDI?

And also can you please tell which all pins on FTDI ar to be connected to ATMega2560 breakout board.

Thanks

Select as Best AnswerUndo Best Answer

user
le_chak (author)ketank2014-08-24

Hi. I'am not used external FTDI adapter. I had Mega2560 board from ElecFreaks with integrated FTDI chip.

But if you need to connect your Mega to FTDI adapter you must connect RX, TX, Reset and Ground pins.

Adapter -> MEGA
RX -> TX (18)
TX -> RX(19)
GND -> GND(any GND on board)
RST -> Reset
Power pin not nessesary because FTDI powered from USB. Also you can power your Mega from this pin.

As i know FTDI programmer emulated COM port and in application you must select COM port corresponding to adapter to upload your sketch.

Select as Best AnswerUndo Best Answer

user
GenAap (author)le_chak2013-10-27

Hey, thanks for you're reply. It ended up for me being that the mega had a bad crystal and I had to send it in to get it fixed. But so far this is the best general response I have seen.

Select as Best AnswerUndo Best Answer

user
foadsf (author)2017-07-18

Unfortunately this error refers to many different issues and there are so many posts here and on other platforms none with a definite answer. Maybe Arduino team should try to give better errors to differentiate. But I have tried to answer the same question here in this SO post:

https://stackoverflow.com/questions/19645441/avrdude-stk500v2-receivemessage-timeout/45167540#45167540

what solved my issue was to go to Tools>Boards>Board Manager... select "updatable" for "Type" on top left and then select the updatable packages below and click on update.

Select as Best AnswerUndo Best Answer

user
anips1 (author)2016-10-16

Make sure you have the right board and the right processor chosen in the Tools>Board, Tools>Port, Tools>processor. If you have a wrong combination of the above 3, you might get the same error. Good Luck!

Select as Best AnswerUndo Best Answer

user
RubenFerol (author)2016-04-12

I have this problem once in a while, when i use my UNO IDE to upload to my Mini Pro. To solve it, i make another upload to my MiniPro and then select back UNO from tools/board, and that's it.

Select as Best AnswerUndo Best Answer

user
non4 (author)RubenFerol2016-04-25

thanks man you realy helped me alot

Select as Best AnswerUndo Best Answer

user
mpilchfamily (author)2013-08-28

What FTDI board do you have? Is it the FTDI Breakout board from Sparkfun? If not then you may not have the pins connected correctly. The errors you are seeing are from the PC not able to get a connection with either the FTDI board or the arduino itself.  

Select as Best AnswerUndo Best Answer

user
GenAap (author)mpilchfamily2013-08-28

Yes, that is the exact board I have.

Select as Best AnswerUndo Best Answer

user
mpilchfamily (author)GenAap2013-08-28

Make sure it's plugged in right. Selection the Mega as your board may not be the right selection here. As the USB connection your using is different than the one used by the official Mega. The board selection is based more on the interface chip used then on the version of Arduino. Look through the documentation for any info on this subject. Also ask in the Arduino forums.

Select as Best AnswerUndo Best Answer