23063Views6Replies

Author Options:

Arduino USB connection problem: usbdev_open(): did not find any USB device "usb"? Answered


I have a problem with my Arduino... I was using it and working correctly but suddenly an issue has appeared....

When I connect the Arduino via USB, the LED (pin 13) becomes ON permanently.... When I uploaded the Blinking example it's still ON and not blinking....

When pressing Shift + Upload this error is appeared:
avrdude: usbdev_open(): did not find any USB device "usb"

I'm using Arduino Uno, and the Programmer is checked on AVRISP mkII

6 Replies

user
Kzandra (author)2015-11-10
user
purpulhaze (author)2013-09-02

Now I'm getting this error and have tried just about everything.

Select as Best AnswerUndo Best Answer

user
steveastrouk (author)2012-12-09

You've damaged the bootloader probably. It needs reloading via the ICSP connector.

Select as Best AnswerUndo Best Answer

user
EngineeRoo (author)2012-12-07

The Arduino works perfectly when I change the pin 13 to another..... but pin 13 still not working.... why?!!!

Select as Best AnswerUndo Best Answer

user
EngineeRoo (author)2012-12-07

It's on COM4 and I selected it from Arduino tools>Serial port
and there is no difference.... LED on pin 13 still ON..... it should blink 3 times when connecting arduino... but it doesn't.... it becomes ON when connecting.

Select as Best AnswerUndo Best Answer

user
bwrussell (author)2012-12-07

I'm guessing it "forgot" which port that it is supposed to be using.

Plug in the Arduino and then go to the hardware manager in your control panel. Look for the Arduino, under COMM or possibly USB, and when you find it it might say which COMM port it is using next to it's name. right click, properties, and then look through the tabs until you see which port it is using. Armed with this knowledge go back to the Arduino IDE and select the correct port under Tools.

Select as Best AnswerUndo Best Answer