Author Options:

Boot disk error? Answered

I recently built two computers with amd fx-4300 processors, geforce 650 ti video cards, generic 4Gb memory, generic power supplies and GIGABYTE 78LMT-S2P motherboards. I installed Ubuntu 12.04 on the systems and began installing various programs I needed. When I was done for the day I shut down the computers and turned off the powerstrip. The next day when I went to start them up, I was getting a boot error. After inserting an Ubuntu live disk into the computer, I checked the hard drive, which opened up no problem and still contained all of the files from the os. The rule out the software I was installing, I reinstalled Linux on both computers, and rebooted, after which point there seemed to be no problem, until I turned off the powerstrip again and I got another boot error when I went to turn them back on. Thinking it might be the disk I was using to install linux, I burned another disk with the same os and tried that, and the problem persisted. The fact that it happened on both systems leads me to beleive that it isnt a hardware defect, but possibly and incompatibility between hardware parts, or a bios issue. Has anyone else ever encountered a situation like this where the os doesn't load after the power supply is switched on and off? If so, what causes it and what can I do to fix it?

Edit: It seems that it actually fails to boot every time it is shut down, though it works fine when it is only rebooted.

Edit#2: Interestingly enough, if i run a hard disk check from the live dvd, and then reboot with the disk in, it loads from the hard drive, but then after the next shutdown, it does the same thing

Edit#3: After doing a disk check and it says no errors, it says to click a button to reboot. When I do this it gives me this message after it reboots,
"Errors were found while checking the disk drive for /.
Press F to attempt to fix the errors, I to ignore, S to skip mounting, or M for manual recovery"
on the one computer I hit f to automatically fix it, which isn't a permanent fix because the drive coninues to have problems, but will boot after i hit f, and then not after i shutdown again. On the other computer, I hit m, and it gave me the message,
"Root filesystem check failed.
A maintanence shell will now be started.
CONTROL-D will terminate this shell and reboot the system."
The shell is from the hard drive, not the cd.


Ive had this same problem with gigabyte boards , ive found that if it wont boot unplug the sata cable from the motherboard and use another port and it should boot fine , for some reason the board had a specific sata port it wanted to boot from and it wasnt sata1 as youd expect , i looked at the bios and tried everything but it came down to the specific port ?? Never had the issue with any other board only Gigabyte?? Its probably nothing else.


5 years ago

Un plug everything USB and try it. It could be trying to boot off of a USB device and not understanding that its supposed to skip them all.

So, just to get this right:
- if you power up the PC, if won't boot,
- if you reboot while the power is on, it works

Sounds like a problem between PSU, hard drive (and/or BIOS)
If the various power lines of the PSU power up in a sequence that makes the hard drive logic wanting to spin up the mechanics, but the 12V is not ready yet, it can go in fail mode (and stay there). In that case the reboot is like a reset signal for the hard drive to do its start logic again and as 12V are now available, it works.

That's just a shot in the dark and unfortunately I don't have a solution for you.

If your PC has a reset button, you could try this: Press and hold the reset button while switching the PC on. Release the reset button after about 3 seconds. If this works and you know about electronics, you could build a monoflop (with an NE555 or even a µC) to force the reset line active for a few seconds after the power goes up.

Basically, I am in the middle of installing ubuntu. After it installs, it reboots and comes up from the hard drive fine. If I reboot from this point it works fine. However, if, from ubuntu on the hard drive, I shutdown, when I press the power button to turn it back on, it comes up with a boot error.

have you changed your bios boot priority back to your hard drive?, I know it should make any difference but on some computers if you leave it on the cd rom it causes issues
also there is lots of help on the ubuntu web sites with lots of forums someone has probably had the same problem as you.
Have a look at this page.

yeah, I switched around the boot order and after that didn't work i tried resetting the bios. still no luck

hi again
have a look at this
fingers crossed it should fix the problem


5 years ago

Run the disk utility and check the HDD for bad or failing sectors.

Check to see if you have the latest Motherboard BIOS.
Also check to see if there is a firmware update for the hard drive.
Also before you turn off the computer, install the latest Ubuntu
Doing a web search for the actual boot error might also prove helpful.

It's not a specific boot error, just the standard boot disk failure, please insert system disk kind of stuff. I tried installing the latest updated and that didnt work.
Could a non updated hard drive firmware cause it not to boot but to be displayed in the filesystem? also, it would boot from the hard drive when restarted, just not when shutdown all the way then powered up again.