Author Options:

Bug on "next" button Answered

Ok as I'm looking thru ibles I often find something that I like and I go to the autors/members page to see other ibles they have posted.  For some reason since the big change on the site it will show only the most recent eight or so ibles posted, and when I click the next button it just refreshes the page but never shows the "next" most recent.  I thought maybe it was just the recent ones and tried it on the views/name/rating tabs and when I click next it takes me back to the eight most recently posted.  I've tried this quite a few times on differant members and get the same result.  I've looked in bug reports and seen a simular post about reading the next 51-100 comments, but this is about actual ibles.  Is this happening to anyone else or is it the iD10t error I am experiancing?


If you can reproduce this at will, I'd love to know more!  The problem here is that as much as I try, on three seperate operating systems, five different computers, and quite a few different browsers, I can't reproduce this effect.

Please let me know what browser(and version) you're using, if you have other tabs open, what they might be on, or if there's anything else running when this is happening.  Anything that might help me figure out what the culprit is so I can pass the info on to get fixed.

Hey, Matt.  As I noted in a separate comment, I have seen this effect intermittently myself (which makes it even more difficult to isolate :-( ).  Here are the gory details of how I view I'bles on my system:  MacOS 10.5.8 fully patched, FF 3.6.3.  I have four tabs always open and logged in:
  1. My comments
  2. Current forum topics
  3. Recent I'bles
  4. Recent Questions
I just tried scrolling through Ed's I'bles, and the Next button worked for me with no difficulty.

Actually, I just installed IE8 on my windows machine to try out comments, and happily, it didn't work.  So now I just need to tote my machine to work so I can show the dev team and see what they can make out of it.

...also...since I have a few minutes right now...I just checked it in Safari and comments don't seem progress there either.  (Though, in all fairness, there's a lot that doesn't currently work in Safari.)

I've been using LED Throwies to check things out, if it helps.  In Firefox 3.6.3 I still can't replicate the problem.

Is it because of the new way it loads the  page? Before you could go directly to:


Now to get to that page you have to navigate from their profile then press back. Similarly you can't navigate to any page of their instructables list by entering the URL, you have to navigate using next and prev. Really messed up some of my Perl scripts.

Eg before you could go to:
Now you have to go to his profile and click next lots.

I think you may be on to it there Jayefuu.  It could be something like the "next" button is more of a refresh in the code.  And that is what seems to be the problem, it wont allow you to go forward past the first sorting.  If you try it refreshes and takes you back to the recent sort by defult.

This problem should be fixed.  Please clear your cache, refresh your favorite instructables page, click "next" and feel confident that it will take you to the following page.

(let me know if it doesn't work)

Seems to be working good now.  Haven't been to any group pages yet.  When I do if there is any problem I'll let you know.  Thanks Mr Bug Czar

I have a solution to your problem. Will PM as it's contraversial. :)

i am using Vista IE 8  version 8.0.6001.18904 on a Dell Inspiron.
No other tabs or windows open.  It happends on every members page as long as they have more than one page of posted ibles.  Kiteman's is the one I used as my test subject because I knew he had over 100 ibles posted. 

Now to confuse things a little bit further the same type of thing happends when I look thru some groups.  But with the group searchs to get to the 2nd or 3rd or farther pages I would have to go back to the "home " of the group and hit the number of the page I want to see.  (I hope that made sense)

See Matt's comment below, and in related bug reports.  Apparently the software gurus rolled out a bug fix that covers all (hopefully!) of the problems with the various Next buttons.  Please reload pages (to clear out locally cached versions) and try again.

you are not alone, damn it.


8 years ago

As posted previously, I have this problem too. It is extremely consistent.  

I saw another report on this a week or two ago.  There is a new Bug Report czar at I'bles (user StumpChunkman).  He should follow up on this in a couple of days.

Instructables Bug Czar...Actually...that title sounds kinda cool...

...I may just have to add that to my resume!  Thanks!

Thanks.  I guess I didn't go far enuff back.  Guess I should have Googled it LOL!

This bug seems to be rather inconsistent.  I ran into it myself today, but just once.  I continued to use the Next button and it worked just fine, at least out to the 30+ range.

On another note, it appears that you cannot manually edit the URL any more.  If you try changing the "OFFSET=" value by hand, it takes you back to the zero-offset URL :-(