77Views4Replies

Author Options:

CDROM stepper motor problem with movement Answered

I have been having intermittent problems with my cdrom stepper motor. I had a four pin motor soldered to a bare copper wire. I used the pins not the little ribbon cable and I left the ribbon cable attached because I figured, as soon as I snip it off I would regret it later. The other end connects to a breadboard that is in line with the stepper input to the EasyDriver motor controller. I have been using GRBL controller on my PC and when I tested it the first time in a vertical position it would just wobble around, not moving up nor down. I thought the stepper motor was bad so I got another one. The second was wired the same way, 4-pins, and it worked in the vertical no problem. Then later, while working on the rest of my project the second cdrom motor that was working did that same wiggle without moving up or down. I realized that the solder connections were very close together and that two pins were electrically connected. I modified the wire to basically a homemade male to male jumper wire. The extra pin made the room I needed to unsolder the two pins. Once again the motor worked up and down with no wobble. I have done nothing to modify the cdrom stepper any further and went to test my motor today after a couple weeks hiatus and once again, wobble with no up nor down motion. At this point I am stumped. I have reason to believe that my solder skills are lacking and that my homemade jumper has broken internally inside my shrink tubing where I cannot immediately see it but If anyone else has had this problem and knows how to rectify it please let me know. I hope there is enough info here laying out my problem and that someone can lead me in the right direction. If it also helps, I have checked my pin out and I do not feel it is backwards or crossed. I checked the resistance between the four pins and the end of my "jumper" and is approximately, 40, 20, 40, 100 ohms for A-, A+, B-, B+, respectively. I am really not sure what these number would mean but my buddy told me to check the continuity from end to end.

4 Replies

user
Downunder35m (author)2016-03-12

These motors have no real power, so test them without a load.
The stepper driver has a pot to set the current for the motor, maybe increasing it a tiny bit might help.
Also check the stepping and if doubt use a 1/8 stepping to drive the motor.

Select as Best AnswerUndo Best Answer

user
dankozi713 (author)Downunder35m2016-03-12

Downunder, I had stripped the platter of all its laser parts and just added a couple of standoffs. That was the only weight to it. Then, I had everything connected and powered up and I put my multimeter on the R75 resistor and TP1 on the Easydriver to get a voltage reading. I tuned the pot from the lowest to highest (and then back down bc it was screaming a little) while running 100 steps so that it was long enough to run the test. None of that helped. It still just jiggles.

As far as the microstepping, I am not really sure how to wire that. I know there are solder points for the "MS1" & "MS2" but I would need to school myself in how to wire them and then recalibrate GRBL accordingly.

Select as Best AnswerUndo Best Answer

user
Downunder35m (author)dankozi7132016-03-13

How many wires on your motor?
There are drives out there that don't use the standard stepper motors....
And even if it is a suitable motor you have to get the connections right to make it spin.

Select as Best AnswerUndo Best Answer