Author Options:

Can not download PDF as a Pro Member Answered

When I try to download the PDF for the 4x4x4 LED and depress the download, I get asked to login. So I log back into, try again and get asked the same thing.  So some how I'm in a loop.
I running on a Mac Snow Leopard, Safari


Is this happening for all pdf's? Can you make sure you are logged in and cookies are enabled in your browser.

Worked fine for the pizza oven. Still fails with Safari on the LED one -- but at the suggestion of another, I did try chrome and I got the LED to download from there. So it's browser dependent. As I say, it loops -- I'm logged in, I depress the download button, and it gives me a new page that says I need to login. So I login again and the process repeats....

You need to configure each browser individually (they don't talk to each other). It sounds like you've got Safari set to either reject all cookies, or to reject cookies from Instructables.com, or maybe it's got an old corrupted cookie.

Try the following in your Safari session and see if it helps:

  1. Select Safari -> Preferences... -> Security
  2. In the Cookies section, select Show Cookies
  3. Choose Remove All to get rid of anything that might be corrupted
  4. Back on the main panel, choose Only sites I visit
  5. Go back to the Instructables main page and Reload

You should have to log in again, and things ought to work properly after that.

Kelsey -- Thanks for the suggestion. Although I was already set up that way and before I sent the help mail I already had tried the cookie clear out trick and logout/in --> unlike Al Gore I'm one of the old "internauts" that really was there in the 1970s :-) Very technical.... Anyway, what is interesting is that the Pizza Oven down loaded just fine with Safari. It's clearly something a little different that is not been handled with grace. Not clear if its that page, or maybe something to so with the web cache. Undoubtedly something interesting about my set up, between Mac, VPN etc. - that trips over it.. Given the number of people that are offering the same complaint, I >>suspect<< hat there just might be some thing on the instructables side that is "not quite perfect" -- but that a few of us some how push into. Love to find some one on their side to look at the logs as my transaction is performed to see what is happening. Frankly the loop - asking to relog in a bad sign. Seems like an error path is confused and headed back to the "start over state" instead of dealing with with error properly. Again -- I think the behavior is a hint... I hit download and some how is not getting the proper creds. Thanks again,

I pretty much agree with your analysis (and I'm one of the Old Guys, too, with good VM credentials!).

Usually (not always!) that login-loop is due to I'bles not being able to read back the cookie it uses to store the fact that you're logged in. Recall that HTTP is a stateless protocol. The only way for a Web server to know that you're you between pages is either by embedding a (stupid) "session ID" string in the URL, or with a cookie. I'bles doesn't use session flags.

The fact that you're only having problem with specific PDFs, not globally with the site, does imply something wrong with some database record on the server side.

The best person to contact directly is user StumpChunkman (Matt Dalton), the I'bles Staff member designated as the interface between the user community and the system developers. He's quite responsive, and it sounds like you have enough technical background to communicate intelligently both with him and with the programmers.

Good luck!

Have you tried using Firefox or any other browser?

Good suggestion. Works with chrome, but still fails with Safari. BTW: Safari worked fine for me trying to download the Wood fired Pizza Oven's PDF. So you tell me.