Author Options:

Cannot edit or add to collection Answered

I am unable to add instructables to or edit my published collection.

Windows 7 Home Premium 32bit,

Mozilla Firefox 35.0.1,


Click "Edit" button and get: "Something unexpected happened, If the error keeps occurring, file a bug report!" (https://www.instructables.com/editCollection/error/oops)

In attempting to add to the collection, when on the page for any instructable, I click the "+ Collection" button, the appropriate dialog pops up, I chose the collection, click the "+ Add to Collection" button, and receive the "Error Adding to Collection, Please try again" dialog.

This has only begun recently, as I was able to create the collection and add Instructables previously.


This issue has been around for awhile.. (over a year to my knowledge)
I ended up moving my collection to a new 'draft' collection. deleting the instructables in the other "published" collection as i went along..
huge pain in the butt!
I'm really surprised they have not fixed this yet..
BTW I tried it on three different computers, IE & Chrome and one computer that had no antivirus or other possible interference..
so obviously this is something to do with their website :-(

Same thing happens to me.. different computers and browsers.. only on published collections..

I am beginning to think that this error is due to having published the collection. prior to publishing (when I had it saved as a draft collection), I was able to add, remove, and edit it just fine. This problem only came about after I published it.

I too am getting the exact same errors. I am using a Mac. Have tried Safari and Chrome without pop-up blocker.

Is there a limit to the number of instructables that can be in a collection? On a whim, I tried to make a new collection and everything went fine with that one.

I have Ad Block Plus enabled, but it was enabled previously as well. I am getting the add to collection chooser popup, as well as the error popup.

I have disabled Ad Block Plus and the popup blocker addon for the site, to no avail.

Have you got any ad-ons running that might block pop-ups?

I thought maybe the issue could be with Firefox, but I just tried with Chrome with the same end result as well.

I just tried again at different time of day with the same result.

Could it be that this is only happening at certain times?