Author Options:

Can't edit Instructable: "SyntaxError: Unable to parse JSON string" Answered

I was almost finished with an Instructable yesterday, and when I saved it, got the following message: "There's been a problem updating your Instructable parsererror SyntaxError: Unable to parse JSON string."

Today I tried editing it again, and got them same error message. I was able to "publish" this Instructable, but still get the same error when I try to edit.

And I don't remember using any JSON string to hold this together?;-)


(Using Safari 5.0.5 on a Mac, not that that should matter).

Winged Fist


Hello. Wile you don't think it matters that you use Safari, it's amazing what one browser will let you do, while another denies access to. Would you mind trying to do the same thing in Firefox and seeing if that works?

Once we can figure out exactly what's going wrong, I can pass on the information to the code-monkeys to figure out how to fix.


Thanks for the suggestion StumpChunkman! I tried Firefox, and it worked fine. And now the problem has gone away in Safari as well.

So maybe the code monkeys can check to see why this error occurs with Safari?

I read in another thread that copying and pasting from MS Word can create problems... That's what I did with this Instructable, so maybe that was part of the problem? But at least the problem is gone for now!

Winged Fist

Awesome! I'm glad to hear.

Yeah, the problem when you copy from Microsoft Word (or other publishing editors), when you copy, you're actually copping all of the formatting information (it's invisible, but it's there). When you paste it into certain places, they try to retain that information which creates issues.

If you copy and paste to a basic text editor before going to anything, you can ensure you get rid of those formatting items (like text edit, or notepad).