Author Options:

Conversion of RS485 data to usb? Answered

I have a keller pressure sensor PAA-33X which gives output in RS485. I also have an rs485 to usb converter(http://researchdesignlab.com/usb-to-rs485-converter-module.html) so that I can get the value directly on my computer for viewing and further processing of that data. I tried the connections but, the converter module only shows that data is being transferred(tx led glows) but not received, when I run the READ30 software. Someone please help me with this in a detailed way.
Thanks in advance.


you have to check whether the baud rate set is same at both the ends and the pin connections. reverse the Tx and Rx connection and try


2 years ago

So you are or are_not using Hyper_Terminal to receive the pressure sensor data ?

I haven't tried. Will it work?

I tried that but, no use.

The RS485 is sending half baud so it does not need a go command.

Get a scope, of any kind, and decipher the baud rate that your PAA-33X is sending.

Then find any USB dumb terminal that can be set to that baud rate

( Take care that the wires do not invert the signal )...

You never give any specific info on what does not does not work, you only state that it doesn't - that is no way offering useful answers ;)
Again: did you configure the software correctly?

Your best option by far will be to buy an RS485 USB converter cable - There seem to be plenty around


Trying to make one will involve programming skills That you may or may not have, as you asked the question I am guessing you do not have these skills.

I made the module(though it was rs485 to TTL converter) myself several times but, similar problem was there too. So, I decided to buy one.

Now I am totally confused.

You have already made an RS485 to TTL converter but it didn't work?

So you bought a commercial converter lead.

You now have a TTL output going into your PC - is that correct

What you want it to be able to read the serial stream?

Hyper terminal should be able to tell you if any data is coming through IF you set it up correctly.

As DU says you need to be specific about what is actually wrong, what you do or don't see at the PC.

No, I have USB output to my PC.

Actually, I made an RS485 to TTL converter to retrieve data using arduino but, it didn't work so, I switched to a readymade converter(RS485 to USB. USB because finally, I want the data to be processed in a motherboard). I used hyper terminal but, there was no data on the terminal. Then, I used 'control centre series 30' software which couldn't recognize the device (maybe because they recommend k102 or k107 converters on the datasheet for this software. They are too expensive for me so, I bought the above-mentioned converter).

I just want the RS485 data on my PC.

You need to beak the system down,


One of the guys I work with built a slick little box for testing rs-232
connections. He basically put a resistor and led across the ground and
5v terminals and then another resistor and led across the ground/rx and
ground/tx wires. Soldered it all together and put it in a little plastic
hobby box with DB9 connectors coming out of each side.

When you plug it in line with the connection the lights indicating
proper grounding and 5vdc for each side of the connection come on. Then
whenever data goes across the line the TX or RX led will come on.

If you are just trying to verify good electrical connections, you could
probably expand on this idea for RS-422/RS-485 and do it with $20 worth
of parts."




several other places to look for hints on how to check the RS485 signal is there

For your cheapo module it does not say if it can do more than connect to another, similar module.
The magic words here are: "Supported protocols"
The Read30 software is totally outdated, a quick Google check would show you that "Control Center Series 30" is current.
And last time I checked even the oldie Read30 needed to be configured first before it could communicate with anything - but I guess since you did not check on the software itself that you did not read the manual either!?

Sorry I forgot to mention that I used 'control centre series30' too. It didn't work so, I thought of trying read30, which didn't work either.

And, the specs of the module say that it can be used to retrieve data from other sensors which use rs485.