Author Options:

Dead laptop Answered

My acer aspire 6920 laptop doesn't boot. I have tried the POWER RESET (as an option specified on the acer website), by removing the battery, unplugging, and holding the power button for 20-30 seconds. This had no effect.

How it happened:
I was playing a game called Warzone2100 on Ubuntu, and it FROZE, so i did a hard shutdown and then.....

When I press the power button the following happens:
>The Cinedash, and power button light come on . The Hard drive and Cd-rom, fan, and HDD start-up as well.
>The hard drive light above the caps lock and num lock indicators flashes seven times consistently, with about a 3/4 of a second between each flash.
>The system shuts off completely
>(without anyone pressing the power button)The system turns back on and nothing happened.
>The system requires a hard shut down.

During this entire period NOTHING shows up on the screen, and the back light stays off.

I think my BIOS is a PHOENIX and according to some research 7 BIOS beeps means its a bad processor. So I think my flashing light could be a Bios indicator.

If my conclusion is true, do laptop processors cost ? and where would I be able to get one ?
Are they easy to install ? are they interchangeable with desktop processors ?
BTW My processor is an Intel Centrino T5750 Dual Core 2.0ghz.

Thanks to anyone who helps me out !


I had problems with my HP zd7000 and had no idea what was wrong with it. Here's what I found helpful, though: find a forums specifically dedicated to your laptop model. They'll have a community that'll be much more well-equipped to help you with your problems. At least, I had luck.

Sounds to me more like the battery is drained and barely holding a charge, and the internal power jack is on the fritz. I'd open it up and check out the jack first. This always seems to happen to my laptops and that's always the problem.

Things like the CD-ROM are still getting power, and if the battery is removed (and the lappy is plugged in) everything still gets power, so I dont think thats the problem. But thanks for your help anyways


9 years ago

Remove the battery + power, then the RAM (usually accessed underneath), leave the RAM out for around 10secs. re-install and boot. It should work, works everytime for my Toshiba lappy.

I tried it, with no luck. But thanks for the tip.