Author Options:

Dell computer question?- not turning on Answered

I have a Dell dimension 2400 that while using it turned off and never powered back on. It was raining that day and I was on the computer and I heard what it sounded like a spark and I kinda saw it too behind where the computer case is(light was off so I saw like a small spark on the wall). I have the computer on a protected surge power strip. This happend before a month before and it was fixed with a new power supply. It didn't turn on also the next morning and it was raining also in the night. I'm thinking a voltage spike cause it .So this time I put in a new power supply and it wont turn on. The power supplys both work(new and older one). So what could it be that is causing it not to turn on? Anyone ever had this problem before? There is a green LED inside that turns on when pluged in but thats it. The power buttons LEDs don't turn on when pushed to power on.


"Fried" mainboard? I'm guessing that this doesn't go "beep" - does anything seem to be powered-up? Is the green LED in the vicinity of your memory strips? L

these dont really beep, unless there is a problem

Last year I was referring to the usual POST beep.


the green led is on and is next to the 20 pin plug and the 2 RAMS memory slots. I did heard it beep once when I first unpluged it and pluged it back in when checking the power connection to the outlet but I havent heard it beep anymore after all the things I've tried when trying to turn it on. I checked the power supplys with a meter and they both work fine on all the voltages on the wires.

The green light is telling you the RAM strips are powered-ip, but no beep is bad news. You could try removing the drives, expansion cards etc and giving it another go but if it won't POST I think you'll need a new mainboard (slight possibility that the PSUs can't supply enough current anymore, but I wouldn't think so for both of 'em) L

That's the weird thing. When I put in the new power supply and pushed the power button it didn't turned on. Then I unplugged it then plugged it back in and I head a beep but by the time I looked I didn't see anything else happen so I did it again and still nothing happened. And looking at the motherboard everything looks ok nothing looks burnt.

"If it's brown it's cooked, if it's black it's -" Things don't have to look burned to be irreparably damaged. If the green RAM LED lights it's telling you that something about the PSU and board works. That the rest of it won't POST suggests it's partially broken (in the can't be mended sense). L (Dell Credit Control have been inept for years, if Customer Services are they same - you're wasting your time with this problem)

I don't know what to do anymore. Do you think I can use the parts in my dell to build another computer? Anyone has any Ideas?

You need to look at what you've got and find out what works. Can you get the use of someone else's machine? Plug-in the drives, memory etc and make sure they work, everything said suggests an irreparable fault on your main board - the processor we don't know about. You probably should buy a new board and see if the CPU works before writing it off. Do you have access to a small computer store who might be able to give you a professional diagnosis? The worst you'll get is not going to be any worse than it appears to be now, but someone who deals with this sort of thing all day could give you something better in terms of real physical help. L

check capacitors, and look for any dark spots on the mobo. if there are bad caps, you can replace them. if there are dark spots on the board you might need a new one... also, try removing the things you added, then try

I have a dell dimension 2400. I have a similar problem. when I turn on the PC it goes into something like command prompt but it locks out the keyboard. When I press control alt and delete it restarts and does the same thing. If i repeat it several times it says that checkpoint USBd has an error. If I leave the computer alone for 10-15 min it starts up like normal. this stated happening after I added a second cd drive and a floppy drive. Everything works though.

. In addition to the things BinaryBoy mentions, also check to make sure you didn't knock the power button connector loose at the mobo when you swapped the PSU. . . You need to check your house wiring - you may have a bad ground. Check the ground at the plug - if the ground is not in good shape electrically, the surge suppressor is next to worthless. Never use an adapter to plug the SS into a "two hole" receptacle. . But a high-quality surge suppressor. Check sites like PCMagazine for reviews and tests.

I checked all the plugs over and over, reseat them all,even the data plugs on everything. the only thing I didn't touch was the button battery. The first time this computer didn't turn on I called the people at dell and after everything they had me do and didn't work I remember the guy tell me that it was either the power supply and/or the memory card and it turned out to be the power supply only. So I'm wondering if this time it's the memory card. = / Is there a way to test them?

. The only way I know to test RAM is using the POST, but you're not getting to POST. . I'd check the continuity of the power switch. Maybe jumper the power-on pins at the mobo connector if I could find the docs.

I did jump the power switch at the connector still nothing happend.

mainboard may be blasted try to disassemble it to the last bit and assemble up again bad power supply may sometimes work in one computer and not n another if you see bad capacitors on board or inside the power supply you should replace them immediately

I took of every plug and cards(modem) according to what the dell suport site said to do. try to turn it on and still no change.

take out everything now (the cpu and memory too) and power up the board. try to get it to beep remove the battery. short the entries in the battery socket together for 10 sec. insert battery again

Sometimes the power supply has a little switch in the back so that you can select 115 volts (U.S.A) or 220 volts (Europe).Make sure you have selected the correct voltage. Also, try plugging straight into a wall socket, because the surge protector might be bad. I have taken apart surge protectors and found the MOV (Metal Oxide Varistor) to be charred. The varistor is what protects the equipment from spikes