Author Options:

Exception (3):? Answered

I had some initial problems with WifiClientBasic. After filling in my SSID and PASSWORD on the WiFiMulti.addAP("****", "****************"); line I saved, compiled, and uploaded. All indications showed success, but when I rest my Adafruit HUZZAH ESP8266 the serial monitor would always show the error



ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 1384, room 16

tail 8

chksum 0x2d

csum 0x2d




Wait for WiFi...

Exception (3):

epc1=0x401003e9 epc2=0x00000000 epc3=0x00000000 excvaddr=0x40067d71 depc=0x00000000

ctx: cont

sp: 3ffef170 end: 3ffef560 offset: 01a0


3ffef310: feefeffe feefeffe feefeffe feefeffe


I tried everything including different USB ports incase it was a low power issue. Nothing seemed to work.

I remember back in the 1980’s in college we occasionally got a non-displayable character on a line of code that would drive us batty with an error we could not understand. So I retyped the line and deleted the original. Worked perfect the first time.

Just curious if you have ever seen this with the Arduino development tool before?

p.s. Thank you for putting together such an excellent easy to follow class! Please keep up the great work!

2 Replies

bekathwiaBest Answer (author)2017-06-06

Nope, I haven't had problems with nondisplayable characters in arduino before, but I have had boards that take a few tried to connect to wifi. Glad it's working now and let me know if you learn more about the error!

Select as Best AnswerUndo Best Answer

LewisH34 (author)2017-07-16

Hi there, I had the same issue, which line did you have to retype?

Select as Best AnswerUndo Best Answer