Author Options:

Favorite button disappears when logged in Answered

Something weird has been happening to my account for the last couple of months. When I'm logged in, I can't see the button to mark an 'ible as "Favorite" at the top of the page, but when I'm logged out, it appears! Does anyone have a clue why this happens? I'm using Google Chrome with Adblock Plus.

See attached screenshot. Logged out is on the left, logged in is on the right.


Instructables is bound to have problems showing up in mainstream standard web browsers from the looks of things. http://goo.gl/VpUXx web standards validator link for instructables.com

If anyone has a script that we can run in our browsers to re install this poorly coded feature into our browsers so that we can go back to enjoying the website and possibly continue contributing by favoriting ibles that we like please post it.

I'm using a dev build of chromium browser but its reproducable across all of my machines.

It might have something to do with the anti-facebook crapware plugin that I've got also but I wont be enabling facebook's tracking crapware just so that I can have permission to re-enable my ability to contribute favorites to the site.

I see exactly the same problem. No adblocking or extensions. Firefox 14.0.1.

No script blocking either?

The favorites button is a script that runs as one of the very last things on the page. If you stop any of the other scripts from running, everything after that script doesn't run.

Since Favorites is basically the last thing to load, if you block anything else on the page, it will not work.

So... since it's an actual feature of the site, would it be possible to put it 'earlier' on the page?

Unfortunately our development team (who spend a lot of time reading and writing code) have decided that the place the favorites button is in the code, is the absolute best place for it.

There are a ton of reasons not related to "I want this to load first and this to load second" to change the placement of something in the code, and they've spent years refining where everything is. I've chatted with them about this issue before and they've assured me that it's where it is for a host of reasons that don't include irritating people with script blocking software.

I apologize for your difficulties, but this is something that's probably going to stay the way it is for a while longer. I will bring this point up to them again, but I'll probably get the same response.

Thanks for the explanation, and for bringing it to the team's attention. It's appreciated.

I'm pretty sure I left that comment when I was at work. There it never appeared. I'm now at home, when I load an Instructable while logged in the favorite button does appear, but there's a delay of 2 seconds before it pops up. I don't see any errors in firebug, I will install it tomorrow morning and check again at work.

And no, no script blocking, ad blocking, greasemonkey junk.... just Firebug.


5 years ago

I have a similar issue on SeaMonkey with AdBlock and NoScript, and I can fix it by (temporarily) allowing scripts, like this:

- Allowing googleadservices.com in NoScript will make the star rating appear.
- Then, allowing facebook.net in NoScript will make the Favourite button appear.

I have to allow googleadservices.com first, otherwise facebook.net is not in the list, so I can't allow that on its own.

Hope this helps someone. It took me a while to figure out.

Can you add a rule to adblock for https://www.instructables.com/ save the changes, then clear the cache and reload the page?

Let us know if it solves the problem or not.

Thanks for the suggestions. I've added instructables.com to the whitelist in ABP (when I copy-paste "https://www.instructables.com/" it just saves it as "instructables.com") and cleared the cache and reloaded, but the Favorite button still doesn't show up. Even completely disabling ABP doesn't help.

I also checked my Javascript settings and it's on "Allow all sites to run JavaScript (recommended)".

Chrome seems to have some weird quirks.... another member had a similar problem, so if you don't mind, can you try the same fix? I know its going to sound a little strange, but it took care of the problem...

Go to settings > Options > Under the hood > content settings --- Select the box for "clear cookies and other site data when I close my browser" and then save and close Chrome. Then open Chrome again, and go to content settings again, and then uncheck the box. Then log back into Instructables.

For some reason, the normal 'clear cookies' method doesn't fully work in Chrome, but for the other member I helped, the above steps took care of the issue.

Nope, it's still not showing up. Thanks for trying to help. Maybe it's time to switch back to Firefox...sigh.

Dang. You don't by chance have a large number of favorites do you? I know that another member had a problem with the button disappearing after favorite-ing over 80 Instructables. If not, then I'm not sure what the issue is...

I would suggest that you leave your OS info and the version number for Chrome so that a developer can look into the problem further.