Author Options:

Flash player being blocked? Answered

OK, so I've been working on computers for years and have never seen anything like this... neither have any of my colleagues.  I am trying to help someone out who has some issues with flash player.  Basically flash player is installed on the computer, but whenever I visit youtube or another site with flash, it just shows a black square.  I have run every virus scan I can think of (MBAM, Spybot, SAS, McAfee Stinger, HiJack This!, Norton Power Eraser, Kaspersky TDSS killer, Combofix, Avira) and all of them come up with nothing.  I have tried reinstalling flash at least 5 times, removing every program that has even a remote possibly of conflicting (using Revo to be sure they are completely removed).  I have disabled every startup program on the computer, updated every driver, rolled back, (then updated) every driver, and verified that all hardware is functional.  I have also disabled their AV and firewall.

Nothing works; except for when the computer is in safe mode.  Then everything works fine.

Can anyone think of anything I am missing?


I did try clearing cache and cookies as well.  I also used multiple browsers (including Chrome; which has flash built right into it).  I used Firefox portable as well... which should be running separately from any settings in the system.

Also; I did Google the heck out of this one before posting, so no lmgtfy links please... ;)



Best Answer 4 years ago

Is it a pro version of windows?

Group Policy security settings will block Flash.
I just made a new group policy for our library and it has flash blocked. I have to figure out which setting it is and turn it back on because there have been a lot of complaints about it. It is possible that it is administrated by a service that has been disabled.
Sometimes services settings are changed by malware or viruses and the changes persist even after it has been removed. I had one disable plug and play so you couldn't use pen drives.
SO the problem is almost for sure either group policy or services or security settings.

OK, so you got me on the right track. Something controlled by the Base Filtering Engine service was blocking it. (I still haven't figured out exactly what yet.) As soon as I stopped that service, everything worked. I still need to figure out exactly what it is that is blocking it since I don't want to leave that disabled; but at least I'm close. Thanks so much for your help! :)

And another thing I forgot to mention, if the computer was ever used on a domain, like a work or school domain and logged on as a domain member the server will push the group policy settings on to the computer. Some of the settings are permanent and persist even after the computer is started as an individual system. For example, running an exe program can be disabled, this is done to prevent people from installing programs on the computer. But this setting is for all users of the computer and it is changed in the services so it persists even after the computer is disconnected from the network.

Well, it's not a pro version... it's just Win8 standard. I didn't think of services though... I will look into those. Thanks for the help! :)

Just a hunch - I had a similar problem. Try installing latest version of Flash.

Then uninstall and reinstall your browser (assuming it is not IE).

That worked for me with Firefox.

Maybe cookies or something? Lol, that is really weird. Is it a compatible version of flash players; 64bit/32bit, correct version for their installation of Windows... I can't really think of anything else. Maybe it is just their browser. Try Chrome, Firefox, even IE. Maybe their version of flash player isn't compatible with the browser they use.

Try out these solutions: http://answers.yahoo.com/question/index?qid=20091219235502AA54T9r

Maybe you need to clear temp internet files.

Yes, it is pretty weird. It is compatible, I've tried every browser I can think of (IE, Chrome [Chrome has flash built into the programming... so that makes it even more weird that it doesn't work on Chrome], Firefox, Opera, and even Firefox Portable [which should run separately from the system]). Clearing Cookies, Cache, etc. was one of the first things I did.

(Also... I did try every Google search I could think of... I usually Google before asking.)

Thanks for the suggestions. :)

At this point I might try emailing Adobe or something, haha.

Man, I can't think of anything else. Glad I could at least try to help :)