81Views10Replies

Author Options:

Formatting Bug Answered

When I am editing an Instructables draft, the ENTER key 'appears' to work, but after I save it and then view it in preview mode it is not formatted correctly. Every line I created to separate paragraphs completely vanishes. I have tried several times to be sure it wasn't an error on my part. It appears that the New Editor has a bug. This bug prevents me from separating paragraphs and correctly formatting my instructable. Also, if it helps I have recreated the same issue using Safari and Google Chrome. Thanks!

10 Replies

user
mikeasaurus (author)2014-06-03

Try hitting enter twice?

You can also try:

Disabling any script blocking add-ons to your browser, like Ad-Block, GreaseMonkey, or LastPass
Making sure you have cookies enabled for your browser
Clearing your browser's cache

After, refresh Instructables.com and try logging in again.

Select as Best AnswerUndo Best Answer

user

Hi again Mike Im still have an issue with extra blank lines on lists, Its a bit random but once the extra line is there I cant get rid of it. (see the screen shots) also the tab doesn’t seem to work either, any ideas?

Select as Best AnswerUndo Best Answer

user

I'm not sure what's happening. Maybe try removing all the formatting and reapplying the list formatting?

Select as Best AnswerUndo Best Answer

user

Hi Mike Im still getting that blank line problem when using dot points, any ideas?

Select as Best AnswerUndo Best Answer

user

I don't know why that is happening. I've had success removing the formatting (and extra white space) and reapplying the formatting.

Select as Best AnswerUndo Best Answer

user

The site seem particularly cranky today, It seems to go haywire after I copy paste text from another step. sometimes I can fix it if close it and open it again, then I delete the space by putting the curser between the dot point and the first letter and hitting back space.

very strange.

Select as Best AnswerUndo Best Answer

user

Thanks mike, I tried fixing it yesterday but it didn’t want to play, today I did exactly the same thing to the list with the dot points and I was able to remove the blank lines (it is a bit random) I still cant get the list with the links to play nice. When I hit enter, its a bit of a lucky dip as to if I get a new line, or a new line and a blank gap line.

It does it here as well (see above) I cant get rid of that gap above between "line," and "It"

Select as Best AnswerUndo Best Answer

user

Ive had a similar problem when making list. i always get an extra gap when i hit enter for a new line. it does it in the forum post too, so my list looks like this.

1 stuff

2 parts

3 thing

thanks

Select as Best AnswerUndo Best Answer

user
goldlego (author)mikeasaurus2014-06-03

Thanks for the prompt reply! I was actually referring to hitting the enter key twice. If I hit it once it will work, but that is not enough to properly split words into paragraphs. Pressing the enter key more than once will not work. Also I tried your suggestion of emptying my browser's cache... Unfortunately that did not work either. Thank you for the input though.

Select as Best AnswerUndo Best Answer

user
mikeasaurus (author)goldlego2014-06-03

I see what you mean. You're trying to add extra white space between paragraphs and the editor removes them and acts just as a paragraph break.

I think that's just how the new editor operates to prevent unnecessary white space.

Select as Best AnswerUndo Best Answer