9231Views15Replies

Author Options:

How do you play audio through both internal speakers (Like an iMac's) and through the headphone port at the SAME time? Answered

I recently purchased an iMac, and I have it hooked up to my flatscreen. I bought an audio cable to connect it along with the HDMI, and is connected through the analog (headphone) port on my computer. I want it to route sound through both internal speakers as well as to my audio cable, but so far I have been unable to locate or acquire the software or settings panel needed. I am running Vista Enterprise 32 bit.

15 Replies

user
lemonie (author)2009-07-19

I'm not too sure on this, I'm reading that:
The video signal goes from the iMac to a flatscreen monitor via HDMI cable.
The audio goes from the iMac (?) to the headphone-socket on a Windows PC.
You want to use the iMac speakers and the speakers on the PC or flatscreen monitor.

Can you explain exactly what is connected to what and how?

L

Select as Best AnswerUndo Best Answer

user
Padlock (author)lemonie2009-07-19

No... The iMac headphones port goes to the TV. I'm running Vista on my mac. So basically just getting the iMac's speakers and the headphone port to output audio at the same time. Normally, when I plug in the headphones it automatically mutes the internal speakers, I just need to know how to disable that.

Select as Best AnswerUndo Best Answer

user
lemonie (author)Padlock2009-07-19

OK that's clear. PCs have this thing called "line-out" which I can imagine the iMac doesn't with it's tidy design.
Option 1 is to disassemble the iMac and see if the headphone jack has a little mechanical-switch built into it which does the muting. I have seen this type of socket before, but will admit to not having taken an iMac apart.
Option 2 is to assume that there's a soft-switch and that it can be disabled. My knowledge of Macs says "if they've decided that the headphone socket is for headphones, then it will mute the speakers"
Otherwise search the internet.

L

Select as Best AnswerUndo Best Answer

user
Padlock (author)lemonie2009-07-19

Okay, so it's a mechanical switch? That's what I was fearing. Do you know if a USB sound dongle would present the solution?

Select as Best AnswerUndo Best Answer

user
lemonie (author)Padlock2009-07-19

The headphone sockets I have taken apart have been mechanical. I don't know what the USB dongle is so couldn't comment.

L

Select as Best AnswerUndo Best Answer

user
Padlock (author)lemonie2009-07-21

Ok, so while running many processes on my computer to purposefully bog it down, I have discovered that it is, in fact, a "soft" switch. I bogged down the computer with a ridiculous task (calculating pi to the millionth digit), then plugged in the headphones - there was about a one second delay, in which both the external and internal speakers where playing music.

Select as Best AnswerUndo Best Answer

user
lemonie (author)Padlock2009-07-21

Interesting. Macs tend to be a bit awkward around things like this, but if it is it must be possible. Nothing in System Preferences > Sound then? L

Select as Best AnswerUndo Best Answer

user
Padlock (author)lemonie2009-07-24
user
lemonie (author)Padlock2009-07-24

Bummer. I always hated trying to open a document with something it wasn't meant to be opened with: "sorry, can't do it's a () document so you open it with this.." Maybe that was just OS9, but it annoyed me. You should be able to do these things or have line-out... Maybe they want you to buy a more expensive and better-featured machine? L

Select as Best AnswerUndo Best Answer

user
Padlock (author)lemonie2009-07-24

As far as iMac's go, the OS is standard across every model. In fact, they're may be a feature in Leopard. I'll go reboot into that and try...

Select as Best AnswerUndo Best Answer

user
Padlock (author)Padlock2009-07-24

Nope. Nothing in Vista - or OS Leopard.

Select as Best AnswerUndo Best Answer

user
iBurn (author)2009-07-19

Control Panel>Hardware and Sound>Realtek HD Audio Manager>Device Advanced Settings.
This should work as far as I know, but I haven't personally tried it.
Good luck though =)

Select as Best AnswerUndo Best Answer

user
Padlock (author)iBurn2009-07-19

My control panel isn't configured quite like that. It has a link directly to the control interface; once inside of the interface, there is nothing I see similar to it.

Select as Best AnswerUndo Best Answer

user
iBurn (author)Padlock2009-07-20

Do you have Realtek HD audio Manager?

Select as Best AnswerUndo Best Answer

user
Padlock (author)iBurn2009-07-21

Yea. The interface is Control Panel >> Realtek HD Audio Manager. Here's some screen shots...

Select as Best AnswerUndo Best Answer