Author Options:

Infared sauna electrical failure - help? Answered


I purchased this sauna used a couple days ago, and its not turning on..

The previous owner sold it as having only an issue with the fuse, but I have exchanged all fuses, and Im assuming its one of the three components that are running in the rectangular unit mounted on top of the sauna.

I will post all the photos so you are able to see detailed views of everything - I have now ordered a replacement for the power supply (s-35-12) as I cant imagine the transformer would short the entire sauna.  internal fuses are all 3 amp, this is the power supply (but the power running from mains is standard 13amp): 


And from what I can tell there is a sort of voltage regulator on that PSU which has a phillips white screw which is used for adjusting.  My guess is that previous owner set it for wrong output and it blew the PSU?

Alternatively there is the main board, but I wouldnt know what to look for, nor how to replace, as it had no particular model number.

I tested current coming from mains to the main board (sorry I dont have technical name for that) and electricity is definitely arriving there, but not sure where (or if) it goes after.  I tried to swap one of the kettle lead fuses for the one on the PSU board, and then power on, but as soon as I tripped the power to on it blew the fuse..

image 1 and 2 are overview, image 3 is writing on PSU, image 4 is transformer, image 5 is main board and image 6 is PSU (which I have ordered replacement for).

Thank you for your help!

10 Replies

icengBest Answer (author)2017-03-04

How many amps was this fuse value when you changed it ?

Click pic if you don't see the whole image...

Select as Best AnswerUndo Best Answer

NigelD19 (author)iceng2017-03-05

Hi, thanks for reply - fuse is 3.0amp clear quickblow - its same that is run in the 4 fuse hubs to the right, and one on the PSU board.


Select as Best AnswerUndo Best Answer

iceng (author)NigelD192017-03-05

Two things to do... (1) Because that electronics bay was flooded with dirty water... You must Remove Mains Power, it needs to have the circuits lifted and the solder side sponged with hot water to dissolve the scud and, then using a Q-tip (ie cotton swab) and alcohol finish cleaning scud between solder joints... And do remove the blown TVS varistor chip wires..

(2) Replace that 3amp with a 5 to 10amp slow-blow because I believe the 3amp is a mistake if the four output IR power lines are each also 3amps...

Select as Best AnswerUndo Best Answer

NigelD19 (author)2017-03-06

thank you for your help.

I swapped out fuse for a 10amp slow blow, and swapped the entire PS - to my surprise it worked!

Very helpful indeed!!!

Take care


Select as Best AnswerUndo Best Answer

iceng (author)NigelD192017-03-06

Pleased to have helped..

Do keep a critical eye on the system after having used it for the first few times, are there any unusual smells, circuit temperatures.

If you like, you can click on the Best Answer by my name...

Select as Best AnswerUndo Best Answer

steveastrouk (author)2017-03-05

Disconnect all the kettle leads, EXCEPT for the one feeding the power IN.

Does it still blow fuses ?

Select as Best AnswerUndo Best Answer

Downunder35m (author)2017-03-05

I would start by testing the componets outside the box.
Get some wire and fuses or better quick circuit breakers.
Check which part is the actual cause for the blown fuse first.
It looks like quite old and corroded, so chances are some capacitor or trace on the circuit boards is causing trouble.
Could also be a short somewhere.
In a lot of cases moisture corrodes lamp fittings and contacts for heating elements - worth checking those seperately to avoid troubles and blown fuses.
With nothing connected to the power supply you should be able to measure the outputs.
If the fuse blows with nothing connected the power supply will be faulty - just as an example for the fault finding start.

Select as Best AnswerUndo Best Answer

steveastrouk (author)2017-03-04

Its just blowing the supply fuse on the PSU ? Or the plug-top fuse ?

Select as Best AnswerUndo Best Answer

NigelD19 (author)steveastrouk2017-03-05

Is blowing the exact fuse that iceng pointed to in yellow.

That fuse has red current going to two locations, one into AC line in on PSU and another that runs over to circuit board into the final hub to the right marked CD


Select as Best AnswerUndo Best Answer

NigelD19 (author)steveastrouk2017-03-04

Ill attach an image to describe better. The fuse thats blowing has two wires coming out of it - one goes to the AC IN of the PSU, and the other one carries all the was over into the main circuit board (where the mains electricity arrives first), into a slot titled CD.

I circled the fuse (in light blue) to show where it is - its not on the PSU itself, although there is a fuse on the PSU as well, which isnt blowing.

Circled in green however, next to the fuse on the PSU there is something sparking when i plug in mains - its a small grey element standing vertically, that is somewhat circular. This popped the last time the fuse blew (the one circled in blue) and a chip flew off.

Select as Best AnswerUndo Best Answer