Author Options:

Instructables App "network error" Answered

I tried to use the Instructables app to write an instructable.

I loved it, writing an instructable as you go and clicking the camera button was great, made it really easy.

BUT when I got done and went to publish it I clicked publish and it said it was uploading photos.  I laid my phone down, Moto G running kitkat 4.4.2 on the counter, when I came back it said network error unable to upload.  So I clicked done and tried to upload again, this time it immediately said network error couldn't upload.  So I completely closed the app tried again, same.  Restarted Phone, same. All the while having a strong WIFI signal.  
So as last resort, I cleared app cache, well, this deleted my instructable........ Those should really be stored in a separate file that is not erased by a cache clear.

So what was wrong? I had a great internet signal, there was NO network problems. Webpages and instructables in the app loaded fast.



having problems uploading ,and keep getting network error. This is how i get mine to work . Open your draft ,select the first sett of photos you had added . I then click on editing tool . A box popped up which says "can not open image " . Delete and re insert that image . Try this for all photos you have added . I had to do this for 30 of 37 images . Now try and publish . This worked for me . Cheers rob

I am having the same issue and I really don't want to re-write this again. Is there a solution to the "network error" message on the app. The error is not even useful it has no details to let you know what the actual problem is and there is no way to send a bug report to get it fixed.

I have been having the same issue. Iv attempted to upload two diffrent ibles on three diffrent networks and I have tried everything suggested to no avail. Just kept getting "network error" or "bad request" Is there some way to take an ible from ones mobile device and upload it using a computer? Is it best to just wait a bunch and try on a later date?

Oh, I completely understand how the instructables are stored. I put that last bit about saving them in a persistent file in case any of the people working on the app were to read this, that is just a suggestion.

My real problem was that when I did go to post it live on the site it said "network error" every time I tried to post. I did close the app completely and relaunch, multiple times. I then rebooted the phone and tried again, I also tried other wifi networks. It would not upload.

Now the first time it had started working. And I tried another little test instructable and it worked fine. So I think the problem is the upload was interrupted and the app would not allow it to resume. The Instructable did not show in the browser under posted or drafts.

The project will stay local on your device until published, you won't see it under your drafts on the live site.

If this happens again try making a change to the saved draft on your device (like adding some text or another picture), then try publishing it again. The change might be enough to 'bump' the connection and upload the change. After it's live, you can edit out those extra parts.

I had the same issue. Also tried restarting. Updated the app before I started today. tried the publish icon, and tried cloud icon too. Same thing. Tried on wifi and 4g. Is there a different way? Can I somehow transfer it to the computer and upload it from there with a solid lan connection?

Instructables created on the app are saved locally, only going on the live site when you sync with the site and publish. Clearing your app cache will delete the locally saved data.

If you have an error message just close the app and relaunch it, then try publishing again.