4567Views13Replies

Author Options:

Lg E970 - Cyanogenmod 10.2 RC - Wifi Not Connecting? Answered

I'm new to flashing ROMs. My phone (an LG Optimus G [E970/ATT edition]) was already rooted and I had unlocked the bootloader, but I wanted to try this to have more control of the phone, and to get rid of the tainted flavor of Android (4.1.4) that came with my phone.

Well it took me two hours; but I finally installed Cyanogenmod 10.2 (Release Candidate) & Gapps on my phone. One problem: it would not connect to my home wifi; which is kinda bad.

I live off of it; I use 10-12 GBs of wifi each month; and I have a 2GB data plan.
When I try to connect, it finds/sees the network SSIDs, their security type, et cetera. I type in the network passcode, but it just doesn't connect to the network. I guess it "trys" to, "pretends" to, I don't know. But I cannot use the internet now without using my data plan (which is okay; the data plan is much faster than it was on stock ROM).

I got the Release Candidate from here: http://download.cyanogenmod.org/?type=RC&device=e970
It should be the only one on there, added November 26th 2013.

Does anyone else have a similar issue, do you think you might be able to help me?

13 Replies

user
BigJohnManBest Answer (author)2013-12-08

Quick and easy fix :
Download : http://downloads.codefi.re/g33k3r/cwm-ATTJB-Radio.zip
reboot into Recovery.
install this zip from where ever you put it on your phone.
Reboot system, Wifi works.

Select as Best AnswerUndo Best Answer

user
RJK1988 (author)BigJohnMan2014-01-01

Thank you BigJohnMan. This was a life saver.

Select as Best AnswerUndo Best Answer

user
tomica066 (author)RJK19882014-10-21

it didnt worked! it just bricked my phone

Select as Best AnswerUndo Best Answer

user
The Dark Lord (author)BigJohnMan2013-12-12

Is there really such thing as a quick & easy fix though? Are you sure this download is legitimate and not malware?

Select as Best AnswerUndo Best Answer

user
BigJohnMan (author)The Dark Lord2013-12-12

There aren't too many malware programs that are installed using the recovery flash installer, but hey I understand your concern. If my phone was broke, and someone offered a fix, I'd try it. If it was bad advice, I would post. I wouldn't insight fear without good reason, even though I spent 5 hours reading through forums to find this fix. When I found something that worked, I made it simple for others who are having the same problem.

Select as Best AnswerUndo Best Answer

user
Sue Turner (author)2013-12-28

Hello, I was having the same problem after using the Cyanogen Installer - nice rom but no wifi connection. I read the post below and followed the instructions - I downloaded and installed the zip - I still had no wifi connection but phone couldn't find my Sim Card either - no network connection. I have also now cleared the cache and data partition, and have ended up with a brick!!!
My phone is a Nexus 4. HELP, please.

Select as Best AnswerUndo Best Answer

user
steveastrouk (author)2013-12-02

Make sure you do a complete flush of the cache and data partition. I have had similar issues over the years, just after a new install.

Select as Best AnswerUndo Best Answer

user

How would I go about that? Boot into recovery and take it from there?

Select as Best AnswerUndo Best Answer

user

That's right. Are you using clockwork recovery ?

Select as Best AnswerUndo Best Answer

user

I installed ClockWorkMod (on stock rooted) ROM Manager app, but when I booted into recovery; it said Team Win Recovery Project.
...so I think TWRP. Unsure though.

Select as Best AnswerUndo Best Answer

user

By the way, what do you mean by the 'data partition'? The SD card, or the internal memory...?

Select as Best AnswerUndo Best Answer

user

In CWM, it says "erase data partition" on my Cmod 10.1...

Select as Best AnswerUndo Best Answer