151Views18Replies

Author Options:

My Eurolab Food Vacumming Machine has conked out !? Answered

Hello,
I have a Eurolab machine which is similar to another post, has stopped working after only 7 x uses. We dismantled the back of the machine and found a broken t-piece in the air line. When we replaced the part, it now blows air into the bag instead of sucking it out. Please can someone help us? We also checked that all the lines were clear. The pump motor works fine, just does the reverse of what the machine should do.

18 Replies

user
steveastrouk (author)2013-02-23

There's a valve in the pump somewhere sticking, or it was the T piece.

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)steveastrouk2013-02-23

The t piece is ok now as i put a new one in. The pump is working and pumping plenty of air, but instead of sucking air out of the bag it is filling the bag with air like a balloon.

Select as Best AnswerUndo Best Answer

user
steveastrouk (author)Charmy6662013-02-23

The T piece may have BEEN the valve.

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)steveastrouk2013-02-23

No i inspected the t piece and it was clear all the way through. No sign of anything in the t piece. does the pump pump air into the chamber that takes the bag or should it be sucking. ( thats what i thought it would do, sucking not pumping )

Select as Best AnswerUndo Best Answer

user
steveastrouk (author)Charmy6662013-02-23

Can you post some pictures ? The one we have has a thing like an aquarium pump to suck the air out. Has anyone else fiddled with it ? I wouldn't trust anything I'd left with a screwdriver and my 13 year old....

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)steveastrouk2013-02-23

I will take pictures tomorrow and send them off to you. Thanks for your help..

Select as Best AnswerUndo Best Answer

user
frollard (author)Charmy6662013-02-23

perhaps the T piece was supposed to bleed/be broken intentionally.

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)frollard2013-02-23

the T piece was broken at the T piece that comes from the pump therefore pumping air into the body of the machine and nowhere else. Once a new T piece was fitted the air went to the chamber where the air gets sucked out of the bag???

Select as Best AnswerUndo Best Answer

user
frollard (author)Charmy6662013-02-23

I'm not insinuating you did it wrong, but...that sounds wrong. Generally diaphragm pumps are unidirectional - they can't be reversed, so unless there is a separate 'suck' barb on the pump, the T connection either had a valve in it, or is hooked up different to factory configuration.

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)frollard2013-02-23

I am adding photos, thanks

Select as Best AnswerUndo Best Answer

user
frollard (author)Charmy6662013-02-24

The T-barb is exclusively to share the suction between the bag chamber and the 'accessory' suction port on the top of the unit (to close external containers, etc)

Your pump is reversed, which MUST mean the valve is stuck or backwards.

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)frollard2013-02-24

Hooray.... I took the pump out and found that there was a suction and pump out port underneath the pump. I had it hooked up to the pumping port as i could not see the suction port. Hooked it up to suction and it is now WORKING even better than before, which suggests to me that the t piece was probably cracked from new and finally gave up the ghost . Cant thank you enough for your help.....

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)Charmy6662013-02-23

I forgot to mention that I tried to contact the manufacturer for advice, but they are based in Russia, and their website is in Russian...so no joy there.

Select as Best AnswerUndo Best Answer

user
steveastrouk (author)2013-02-24

You're going to need to find where the pump's valves are then. Can you take the lid off the pump ?

Select as Best AnswerUndo Best Answer

user
RavensCraft (author)2013-02-23

Did you remove any electrical connections?
Maybe the motor is running backwards
because it's wired wrong.

Select as Best AnswerUndo Best Answer

user
Charmy666 (author)RavensCraft2013-02-23

No Never touched anything electrical, only thing i touched was the T piece. definatly no valves etc in T piece

Select as Best AnswerUndo Best Answer