7709Views17Replies

Author Options:

Need your help to fix my Nintendo 64 Answered

hey, Well i was cleaning my room one day and i found my old nintendo 64 and i also found its star wars games and i really wanted to play it but something happened and it ain't working. Problem: Well basically i plug in the system to my television, the whole thing starts up the red light , lights up in the console , but nothing comes up on the television screen... i tried plugging again and again checked all the connections but na na...nothing came up. The same problem occured once and then i worked fine but now it aint coming back. I really wanna play it but there is nothing showing on the screen... Condition: I bought the console new brand about 7 years ago and it was working fine. then i got my playstation so i just put it aside. The video in and audio in cable is a bit broken at the console joint but i fixed it. There is one thing on the top infront of the catriage slot which has the sticker removed... Please help.

17 Replies

user
ashannon1 (author)2011-10-25

you can use a small pair of needle-nose pliers to unscrew it. Also, if you don't have a jumper PAK (Or have a faulty one), you will need to get an Expansion PAK to replace it, the expansion pak adds 4 MEGS of RAM to the N64, and you don't need to use the jumper pak on ones that don't need the expansion pak, it will run the like normal

Select as Best AnswerUndo Best Answer

user
An Villain (author)2011-01-30

Make sure the game is ALL the way in, mine has this problem and usually if I pound on the top of the game pak (cartridge durability FTW) it works just fine. Also, you may need to use the "jump start" method explained by gimmelotsarobots. These are the most common issues with a Nintendo 64, and if it continues to malfunction, you may need to crack it open and see if all of the cables are still in 1 piece.

Select as Best AnswerUndo Best Answer

user
gimmelotsarobots (author)2010-01-02

Had this problem. With mine it was the power switch. The console turns on, but not everything initiates. I have to turn my N64 on really fast with a certain flick of the wrist. I don't feel like tearing it apart because I don't really mind.

Select as Best AnswerUndo Best Answer

user
Steamdnt (author)2009-12-17
Good thing I decided to come back Eh?


Anyways, is the jumper pack inserted? (under than small door in front of the cartridge on the control deck)
Also, to remove the Inverted HEX screws you can do two things
1) buy a GAMEBIT screwdriver from the internet
2) drill a hole beside the screw and pop the console open.

 

Select as Best AnswerUndo Best Answer

user
arylic (author)Steamdnt2009-12-29

thanks mat, ill try that. I would use the drill method.

Select as Best AnswerUndo Best Answer

user
11010010110 (author)2009-02-01

open and clean the heck out of it use new cables

Select as Best AnswerUndo Best Answer

user
arylic (author)110100101102009-02-01

I can't open it the dam screws are nintendo screws. The new cables hard to find where i live.

Select as Best AnswerUndo Best Answer

user
11010010110 (author)arylic2009-02-02

nintendo screws can be opened with a modified flat screw driver

Select as Best AnswerUndo Best Answer

user
DataByne (author)110100101102009-12-15

Not on the N64, it uses bolt like screws instead of the tri-wing screws. I have the exact same problem on my N64, trust me, new cables don't fix the problem. I also live in Ohio, not very tropical.

I'll try cleaning the contact points I can reach and see if that helps.

Select as Best AnswerUndo Best Answer

user
skunkbait (author)2009-01-31

Try cleaning all contact points with rubbing (isopropyl) alcohol. Also, try blowing out all dust with a light compressor or a hair dryer (no heat). I've seen these machines get moisture and dust inside, and that's often the problem.

Select as Best AnswerUndo Best Answer

user
arylic (author)skunkbait2009-02-01

What do you mean by contact points sir ?

Select as Best AnswerUndo Best Answer

user
skunkbait (author)arylic2009-02-01

Well, anywhere that metal touches metal. Also, if the cartridge and console have electronic strips on them, those are important too.

Select as Best AnswerUndo Best Answer

user
arylic (author)skunkbait2009-02-01

i tried but still the same thing happens.

Select as Best AnswerUndo Best Answer

user
skunkbait (author)arylic2009-02-02

OK, if you're unable to disassemble and clean it, I really don't know what else to do.

Select as Best AnswerUndo Best Answer

user
arylic (author)skunkbait2009-02-02

I can disassamble it but the problem is that i can't open the darn screws.

Select as Best AnswerUndo Best Answer

user
skunkbait (author)arylic2009-02-02

I used to have problems with my electronic gear while living in the tropics (Papua New Guinea). Once they quit working, it was always a matter of getting the dust, moisture and corrosion out. After that always store them in a very dry place.

Select as Best AnswerUndo Best Answer

user
arylic (author)skunkbait2009-02-02

Ohh..ok....i can't it to work still...

Select as Best AnswerUndo Best Answer