777Views3Replies

Author Options:

Oscilloscope not focusing (Telequipment DM63) Answered

Picture of

I have a Telequipment DM63 CRT storage oscilloscope, and it has been working correctly for the past few months.

Usually after 5-10 minutes to warm up, I have a sharp trace on a dark screen, but recently it has stopped focusing correctly. The screen now stays fully illuminated indefinately, and the dot is stuck as a 1/4 by 1/8 rectangle. The intensity and astig controls appear to be working correctly, but the focus does not appear to be doing anything.

I've found a couple of old threads on other forums suggesting that the issue is likely to be a damaged resistor between the power supply and the focus control, or noise from the power supply itself.

Thanks in advance for any ideas or suggestions.

3 Replies

user
steveastrouk (author)2012-01-19

The telequipment manuals are downloadable. It will be a dry joint or a burned out resistor.

Steve

Select as Best AnswerUndo Best Answer

user
caitlinsdad (author)2012-01-17

That's interesting, can you use the scope on itself to diagnose the problem?

Select as Best AnswerUndo Best Answer

user
The Skinnerz (author)caitlinsdad2012-01-17

It is still just about useable to pickup simple waveforms, but accurate measurements are out of the question. I should have time to take the side covers off and have a look inside tomorrow.

If necessary I can get hold of another oscilloscope, but I'll see if there are any obvious hardware failures first.

Select as Best AnswerUndo Best Answer