96Views20Replies

Author Options:

Picture Bug Answered

When I try to click on a photo after the first people provide to show the steps, it continues to show the first photo and none of the ones I click. It's almost like a broken link but it has to do with a setting on my computer and have tried to fix it but can't figure it out. I'm running a windows 7 machine and Firefox 9.0.1.

20 Replies

user
Kiteman (author)2012-02-09

Any chance of a screen-shot or the URL of the project(s) this is happening on?

That's the kind of thing that helps the development team so much that they give away pro memberships...

Select as Best AnswerUndo Best Answer

user
mdstb (author)2012-02-15

OK, figured out what was going on with my system. Not sure if this is what's going on for the others, but "NoScript" add-on for firefox was disabling the scripts for the pictures. Even after I gave permission for the whole site it was still doing it, so I disabled it and restarted firefox, then re-enabled it and tried it. Works fine and no longer an issue.

Select as Best AnswerUndo Best Answer

user
splash (author)2012-02-09

[SOLUTION]. I use the no-script add-on for Firefox. Clicking thumbnails functionality is restored when allowing doubleclick.net to run scripts. It's seems that some of the functionality has now been tied to allowing advertising?

Select as Best AnswerUndo Best Answer

user
ksexton1 (author)splash2012-02-10

I'm also having the problem, on firefox with adblock plus. I unchecked the one rule for instructables, no change. There are many rules for doubleclick.net, not seeing which to disable, and trial and error isn't getting me anywhere yet. If I turn off adblock plus, the site works, I only installed it anyway to stop some ads on a live ustream that I watch, where each ad meant a missed portion of the video.
Anyone have any tips on how to find the rule that messes with the pictures here?

Select as Best AnswerUndo Best Answer

user
fzumrk (author)ksexton12012-02-10

The Adblock plugin for Firefox appears to be the culprit. You can disable it by clicking the Adblock icon and selecting "disable on instructables.com".

Alternatively you can add a filter rule by clicking the Adblock icon and selecting 'filter preferences'. Select the 'custom filters' tab and select 'exception rules'. Click the 'add filter' button and fill in the following for the rule:

@@||www.instructables.com^$document

Make sure the 'enabled' box is checked. Close out of the Adblock preferences window. You may have to re-start Firefox before the changes take effect.

Select as Best AnswerUndo Best Answer

user
ksexton1 (author)fzumrk2012-02-11

@@||www.instructables.com^$document that worked, thanks

Select as Best AnswerUndo Best Answer

user
gmoon (author)fzumrk2012-02-10

Yep, there's been some scripting changes here, and Adblock Plus (and possibly NoScript) are interacting with the site at some level.

Personally, I won't be disabling either (I tried that once after being promised there would be no autostart ads, but then the Craftsman ads hit).

Select as Best AnswerUndo Best Answer

user
klixtopher (author)splash2012-02-09

Thanks for mentioning the 'advertising' bit. This was driving me nuts, but when I saw that I thought - wait, I just added AdBlockPlus! Disabled on Instructables and now problems! Thanks!

Select as Best AnswerUndo Best Answer

user
Super_Geek (author)2012-02-10

Confirmed, Ad Block now blocks the changing of images on pages with more than one image.. If you disable it in add-ons the images change again, but this is not a real option.

Select as Best AnswerUndo Best Answer

user
Kaljakaaleppi (author)2012-02-10

I don't have any scripts from doubleclick showing up in noscript. Disabling adblock does not help. And I'm not leaving noscript for one site :(. This is sad, because quite a lot of the instructables gets really confusing without the rest of the pictures. Fix this, and I'll be back on instructables!

Select as Best AnswerUndo Best Answer

user
Teshna (author)2012-02-09

I had same problem... a friendly user in here mailed me, that if i had some adblocking program, i should try and disable it. It worked for him, and me.

Select as Best AnswerUndo Best Answer

user
ro0ter (author)2012-02-09

Win2003ServerR2x86/Firefox10 same problem.

Problem is on all instructables with more than 1 picture.

Problem happens whether logged in or not.

Win2003ServerR2x86/MSIE6.0.3790.3959 - problem is not present (IT WORKS ON MSIE).

Might be an update of firefox which spoiled the thing. With firefox only 4 cookies change, there is a single request firing: http://www.google-analytics.com/__utm.....

Select as Best AnswerUndo Best Answer

user
fzumrk (author)2012-02-09

Here is a screenshot: http://tinypic.com/r/2q8n9qs/5
Clicking the thumbnail highlights the thumbnail, but does not change the larger picture.

Select as Best AnswerUndo Best Answer

user
fzumrk (author)2012-02-09

I have the same problem. I am running Windows XP SP3 with Firefox 10.0. I get the same behavior whether I am signed in or not. I have tried clearing Firefox's cache and cookies and restarting, but it does not fix the issue.

If I open the pages in Internet explorer they work fine.

Select as Best AnswerUndo Best Answer

user
splash (author)2012-02-09

Here's a sample:
https://www.instructables.com/id/Printed-Circuit-Board-PCB-Sprayer-Machine/

Clicking on the thumbnail does not change the picture on - work (firefox 10 on Windows 7) and home (Firefox 10 on XP SP3)

I also have Internet Explorer 9 and Chrome on Windows 7 @work. The page displays normally with those browsers. Appears to be an issue with firefox.

I also tried clearing cache and cookies on Firefox and get the same behaviour.

Select as Best AnswerUndo Best Answer

user
splash (author)splash2012-02-09

Didn't think to check until after I posted, I have an Ubuntu VM, same behaviour in firefox 10 on Ubuntu.

Select as Best AnswerUndo Best Answer

user
Hoopajoo (author)2012-02-09

Same issue here, happens on all instructables that have multiple pictures. Using Win7 with Firefox 10.0.

Select as Best AnswerUndo Best Answer

user
Botanikas (author)2012-02-09

same for me, can only view first photo. i'm using win 7 and firefox 10.0 (same problem was on firefox 9.0.1 and IE)

Select as Best AnswerUndo Best Answer

user
mh76dk (author)2012-02-08

Ubuntu w/ firefox same problem (probably older versions but since its a common issue i didnt bother to check)

Select as Best AnswerUndo Best Answer

user
Michael_Bell (author)2012-02-08

Have the same problem, on windows xp, though. Made a seperate post before thinking to check for multiple posts... oops.

Any luck fixing the problem?

Select as Best AnswerUndo Best Answer