Author Options:

Power Electronics: power converter Answered

I have been running through example questions for an exam I have coming up; the following picture is a condensed version of half a page of working.

My lecturer gave us the solutions and a few steps between beginning and end to get to the solution so we could work it out. However, as you can see the picture below I got 30.6A whereas she wrote 54.2 down.

The problem is to "Find the maximum values of the average" (done this bit) "and rms thyristor currents for any firing angle, alpha.". The values of R and Vs are in the diagram. Alpha is assumed to be 0 since then the thyristors will conduct for the greatest possible length of time.

I think she may have got to the end then forgotten to square root of Pi before multiplying Vm/2PiR by it. Does anyone agree?


So NOT for any alpha (stupid editor doesn't do Greek), but the specific case when alpha= 0 ?

Well that's what the question says, in which case my answer underneath the downwards arrow would suffice wouldn't it? But she also gave a numerical answer for average and rms current through the thyristor; since it's on for longest when the firing angle alpha is 0 then that would give the max possible average and rms current right? I was trying to work through for when alpha=0, at which point her answer and my answer disagree.

Hang on a minute, if you're in full conduction, isn't it just Irms= Vrms/3 m= 76 A ?

For anyone that finds this later, the correct answer IS 76.6A. When alpha is 0 the output is sinusoidal so you can use V=IR and Vm = Vrms*sqrt(2). This would match up with the answer from integrating had I (and my lecturer) got the integration right. I found the correct expression, plugged in R, Vm and alpha and got 76.6 as expected.

Geez, guys. Do you really have to do office hours online?!?

I'm still teaching him, not employing him. Turns out his lecturer can't do math(s). Steve

:-) You do know I was just rattling your cage, right? :-D This was an excellent Question for James to post, but you guys got it all resolved before I could even Feature it...

Of course I do- like I said, it transpires that the worked example his lecturer had set didn't work - James worked it and hadn't seen the limiting case, which was asked for, and just means I=V/R !

I don't work with him. Yet. :)

How annoying. It won't let me add text to my answer with the new editor. :( Luckily I'm in the habit of copying stuff I'm about to post before doing so since Robot frequently swallows what I've spent ages typing. Please see text.txt

I just tested this explicitly by creating a question, then going back to [Edit question]. It worked fine for me (MacOSX 10.5.8, FF 3.6.3), putting my original text into the edit box. If you're able to reproduce it, would you mind posting a bug report?

I just tested the [Edit] capability on one of my recently posted forum topics. It did put the original text into the editor box and let me modify/add to it. Perhpas you were caught in a rollout glitch?