136Views8Replies

Author Options:

Problem in Uploading to Arduino Dicimila Board Answered

Hi i m using Arduino Dicimila For my project. When i upload programs i got Error with this Msg::::Binary sketch size: 2380 bytes (of a 14336 byte maximum)avrdude: stk500_getsync(): not in sync: resp=0x00avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51Before that i done many uploades :), I've selected correct  port and Board... But still uploading problem...Can anyone help me to over this...?

Tags:Arduino

8 Replies

user
Bot1398 (author)2012-03-25

You might have not installed the drivers for arduino install them and it shoul work

Select as Best AnswerUndo Best Answer

user
astroboy907 (author)2011-11-21

Try using a different USB port. My Mac does this all the time even if I select the right board and port (Usually for me I cannot use a USB hub, try directly plugging it into the computer)

Select as Best AnswerUndo Best Answer

user
sabari1000 (author)astroboy9072011-11-21

Thanks for the Quick reply :). Now i tried the other USB Ports also but it remains the same. Not Uploading :

Select as Best AnswerUndo Best Answer

user
astroboy907 (author)sabari10002011-11-21

hmmm, have you ever taken the chip out? I put mine in backwards once and I'm pretty sure it gives the same error :)

Select as Best AnswerUndo Best Answer

user
sabari1000 (author)astroboy9072011-11-21

Yup.. i too took out the chip and and placed a new chip correctly :) :)

Select as Best AnswerUndo Best Answer

user
astroboy907 (author)sabari10002011-11-21

if it is a different chip than you usually use, it may not have the bootloader installed, or it may be a newer version of the bootloader. Try setting the board to an Arduino Uno

Select as Best AnswerUndo Best Answer

user
Libahunt (author)2011-11-21

Have You tried holding down reset button at the same time You click "upload" in the UI? I have a foggy memory it might have helped with my Duemilanove once, but I did not take a good note really.
Also restarting the computer is always worth trying.

Select as Best AnswerUndo Best Answer

user
sabari1000 (author)Libahunt2011-11-21

Ya... i did Holding RESET for a time,while Uploading but it increased the Uploading Time and finally Shows the Error...!

Select as Best AnswerUndo Best Answer