Author Options:

Problem with adding video -- popup box gets stuck Answered

While reading another user's bug report about video embedding, I tried to do one of my own to see if I could reproduce a problem. Instead, I've found one of my own.

On FF 3.6.13, MacOS 10.5.8, when I try to include video through the rich editor, the popup box seems to "hang" indefinitely (see attached).  This happens with Instructables and if I try to embed a video in a forum topic (like this one :-).

I have a video on YouTube. I capture the embed code (which is a different format than before, no longer XML) and paste it in. I click OK. And it just sits there. No spinning wheel, no nothing, it just doesn't do anything. The OK button does turn yellow when I click it, but the process never completes. The other buttons work, so it's not like the whole thing is hosed.

UPDATED: The problem is generically with the embed-video popup interface, not with video I'bles. Thanks to M4industries for helping me isolate the issue.


I had the same problem.

I fixed it by going onto the embed tab under your YouTube video and check "Use old embed code".

I embed videos by using the box on the side of the Instructable editing page. It is orange bordered and isn't a pop-up like the flash-based one that seems to have problems.

Thank you for the suggestions. Using the old XML-style embedding doesn't make a difference with the popup box. It still sits there indefinitely.

What do you mean by "using the box on the side of the Instructable editing page"? Could you post a screenshot showing what you mean? I followed Submit -> Video to get the screen above, and the icon in the editor window is the only interface I see.

Huh?!? I don't see that middle section at all, not on any of the three kinds of Instructables editors. Could you show the URL of that display? Even better, how you navigated to get to it?

I went to submit, video, entered a title and description, then hit the bottom button that says "Save and add video". Then refer to the middle bar from the previous comment.

Ah, ha! Thank you very much. I didn't do the second step. I "assumed" (yes, I know the saying :-) that you incorporated the video with the description text in one nice interface.


Bingo! Okay, thanks. There's still the bug with the popup box, so I'm leaving this bug report up as unresolved. But now I can go back and answer the other user's problem (crediting you with giving me the solution).