Author Options:

Punctuation marks, substitution in text Answered

I've noticed that when I put something in quotes, in a step instruction for example, the previewed and published text will have substitution of nonsense characters. I've noticed this on other instructibles by other authors, so it's not just mine. But, is this my computer, the browser (Firefox), or the Instructibles website programming? Has anyone else noticed this? Hope this helps.


I linked to this thread from Cman's Stone Sign instructable. I too am using Firefox and have the same issues. I wrote my first instructable using Word 2007 and used cut-and-paste to move the text in. It looked fine when pasted, but showed up with nonsense characters for single- and double-quotes using standard keying sequences. I know I have "curly quotes" set (I was a copy editor in a previous life), but on my next instructables I'm going to try saving the text out into Wordpad or Notepad as plain text to see if the problem continues to appear. If it does, I'll try it on one of my other browsers (I run five for testing purposes)

Thank you! If you have the opportunity, please post your test results along with screen captures.

On your first suggestion, you "should" end up with normal results, provided Notepad is smart enough to "untranslate" the curly quotes back into basic ASCII characters (apostrophe, ASCII 39, and double-quote ASCII 34).

For your second suggestion, the browser you use "should" be irrelevant. The problem is that the text entered into the box contains non-ASCII characters. When those are received by the I'bles server and processed, the resulting output contains the nonsense that C'man and you have observed.

This mangling is actually much more general than your curly-quotes. It applies to all non-ASCII (extended) characters included in text, such as the GBP symbol, fractions, accents, and so on. I've documented the bug, but it's not as high on the Staff's priorities as some other bugs.

Here's an example of the bug in action. Text was written in Word 2007 and the browser was Firefox 3. I will post further tests using Notepad.

Instructable bug.JPG

. That definitely looks like you are copying curly/smart quotes from Word. Set your Word document for ASCII text only. No Unicode, no smart punctuation, &c;.

I copied my Word text into Notepad. I got the same issues. The first capture is from the Notepad file (I highlighted to characters of interest), and the second is after I pasted it into my instructable. Thoughts?

Capture 1.JPGCapture 2.JPG

. You need to replace the Greek pi and the squared symbols with HTML entities. . & #928; and & #960; (delete the space before the "#") for Π and π . & sup2; (delete the space before the "s") for ²

. Can you set your word processor to save as HTML? That may convert the special characters to entities.

Creativeman, a lot of us are confused. We suspect that it's some non-default configuration you have on your computer. Normally, when you use apostrophes ("single quotes") they should just work. Similarly, if you use double quotes (shift-apostrophe on a standard U.S. keyboard), they should also just work normally. You say you're using Firefox. Have you configured it to use some non-standard fonts? Have you configured your system to use something called "smart quotes"? These are special Windows-specific extended characters, which look like printed quotation marks (different at the beginning and end of a sentence). If none of this terminology is familiar to you, I don't think we'll be able to be much help just using words. Try getting a screen-capture image showing your problem, and attach it to this forum topc.

Thanks. The problem lies in the quotes, as far as I know I don't use "smart" quotes. It's not that serious, I will just work around. Cman


9 years ago

Yeah, like NM says it's usually a problem with "smart" or curly quotes, usually from cutting and pasting the text in from your word processing program. It shows up for some other command characters as well; the word processing programs put in some other things our site doesn't parse, and you get the nonsense characters. It's on our list of things to fix, though not terribly high priority as it's easy to mod manually.

Thanks guys, but I'm not getting it...easy to mod manually???? Curly quotes??? Haven't seen this terminology before. I don't cut and paste, rather type directly into the box(s) provided. I have one unpublished ible that I have tried to correct several ways....no luck! Thanks again, this is an awesome website, masterful programming! Cman

> mod manually? . You can input many special characters using entities. See earlier link. . Try this: . Tools:Options:Content:Fonts & Colors:Advanced - make sure "Allow pages to choose own fonts, ..." is checked. . Tools:Options:Content:Languages:Choose... - English/US . If that doesn't work, I'm lost.

Well we're both lost...all that was already set...I just won't use quotes, apos, etc. makes it a problem to read others though....oh well. Cman

. The problem seems to be on your end - I don't have that problem and no one else is reporting it. Do you have an add-on that is automatically changing to smart quotes? An app running in the background?

Thanks NM...you could be right...don't know about the quotes, but feel it's not worth the effort at this point. Thanks for your help though.