4059Views113Replies

Author Options:

Report Bugs! Get Free Pro Memberships! Answered

Picture of

Sadly we at instructables aren't always perfect, and when we aren't this results in bugs on our site. These bugs annoy us more than anything, and we want to work diligently in squashing them as soon as we can. To encourage this, we are offering free pro-memberships to those who submit good bug reports that allow us to fix things.

How to Submit a Good Bug Report?
1. First off be descriptive, what did you do to get the bug? Can you reproduce it? What were you doing before the bug? Being very descriptive is key to allowing us to find the problem. Bugs that we can't consistently reproduce will take much longer to get fixed.
2. Include computer specs. What is your Operating System and Browser? what version is your browser?
3. Pictures! Pictures! Pictures! Take screen shots of the issue, before and after if you can.

Exploiting the bug will disqualify you. We encourage white-hattery around here. Any knowledgeable exploitation will not be rewarded.

Good Luck, continue to post bugs to the forums and from this point forward we will be keeping our eyes peeled for good bug reports!

50 Replies

user
frenzy (author)2012-01-20

Hey!

Thanks for all the great bug reports, i've filed them and we will be working on fixes in the comming months. Please continue to submit bug reports in the forums so a staff member can get to them.

-Gregg Horton
QA engineer

Select as Best AnswerUndo Best Answer

user
bricabracwizard (author)2012-01-16

https://www.instructables.com/answers/Why-do-shortcuts-not-appear-even-though-Ive-hig/

Select as Best AnswerUndo Best Answer

user
sunshiine (author)2012-01-16

The pictures in each step of my instructables do not appear in the box to be viewed larger even though I am logged in and I am a pro member. I noticed this was a problem viewing another members Instructables also.

Select as Best AnswerUndo Best Answer

user

This is also happening to me!

Select as Best AnswerUndo Best Answer

user
bricabracwizard (author)2012-01-16

The rating system sometimes works, sometimes doesn't. Sometimes shows the stars when it's rated sometimes doesn't. I have tried this on various computers. My preferred browser is Google Chrome and usually on a Mac, iPhone or iPad. But I've heard about this problem from people who have used different systems to mine when they have tried to rate me.

Select as Best AnswerUndo Best Answer

user

Even on this page when I renewed it the stars that were up the top have now disappeared!

Select as Best AnswerUndo Best Answer

user
curious youth (author)2012-01-15

graphical search is only working when right click and open in a new tab.

refresh doesnt fix

im using windows xp professional with google chrome

also now and then the add comment button seems to be a link to the top of the page. refreshing the page seems to fix it though

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)2012-01-12

Anyone monitoring this page?

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)2012-01-12

Time to start a new thread...

Comments have stopped working. Reloading or refreshing the page has stopped working (used to fix the problem).

Can't get comment editor to load.

Using Safari on a Mac. Tried Firefox and have same result.

Prior to today there were no issues with comments.

Anyone else?

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)canucksgirl2012-01-12

Seems to work now if the page is reloaded.

Select as Best AnswerUndo Best Answer

user
Goodhart (author)2012-01-11

Earlier today I couldn't open a forum topic directly....couldn't even post it in the bug reports.....had to EMAIL it in *sigh*

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)Goodhart2012-01-12

LOL... that's why I found this page yesterday and reported (after an email), because ya, there was a "bug" in the "bug page".... :D

Select as Best AnswerUndo Best Answer

user
Goodhart (author)canucksgirl2012-01-12

I couldn't open ANY forum directly....but I could from my message "shortcut" :-)

Select as Best AnswerUndo Best Answer

user
monsterlego (author)canucksgirl2012-01-12

I was going to post the prob in questions but it cleared up before i did.

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)2012-01-11

I tried to email you guys because the "Project of the Day" (Deer Fly Traps) image is not loading on the home page.

I figured no one got the email, so I tried going to the "BUGS" page, but its now not loading either.

I get a "Please excuse me, that was very impolite..." message and a lot of code...

BUGS PAGE LINK

Select as Best AnswerUndo Best Answer

user
kelseymh (author)canucksgirl2012-01-11

Looks like it got fixed some time between 5:33 and 6:50 pm (San Francisco time) today.

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)kelseymh2012-01-11

I'm glad they figured out the issue, and thanks for letting me know. I was beginning to wonder because it started right after last nights update, and I noticed here and there a few temporary "hiccups"...

btw, San Francisco is Pacific Standard Time. I'm in Vancouver (Canada), just above San Fran. :D

Select as Best AnswerUndo Best Answer

user
kelseymh (author)canucksgirl2012-01-11

:-D You've seen how international the membership here is -- I've started using location-based time references rather than the proper names, because sometimes folks don't know what "Pacific time" necessarily means (let alone "Daylight Saving time" vs. "Summer time").

I spent a year and a half as a post-doc at UBC (we lived in a basement suite in Jericho, just a block from the water!). I was more partial to the Canadians, and that cozy ballpark at QE Park -- $6 seats three rows back behind first base! :-).

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)kelseymh2012-01-11

Very true. I didn't mean to sound anything like those "busy bodies" that have nothing better to do than "point out things" to people. :)

That must have been an awesome time for you. That is a great area of Vancouver and you can't go wrong with the ballpark for entertainment. I'm partial for the Canucks, as most people here are, but for $6 you can't even get parking at the Arena.

I actually live in the suburbs, but most people outside of the area wouldn't know the difference anyways. lol

So just out of curiosity where do you reside now?

Select as Best AnswerUndo Best Answer

user
kelseymh (author)canucksgirl2012-01-11

Which suburb? Most of Van seemed like a suburb to me (except for downtown), kind of the way L.A. does. Unlike here, though, the people were much more openly friendly :-)

I'm currently in Northern California, near Sacramento.

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)kelseymh2012-01-11

Oh, I love that part of California. :D

Out here, we call the entire area the Greater Vancouver Regional District or GVRD. It consists of Vancouver, West Vancouver, North Vancouver, Burnaby, Richmond, Surrey, Delta, New Westminster, Coquitlam, POCO, Langley and White Rock. After that all the cities are considered the Fraser Valley.

It's basically one big city with unassuming roadways that mark the boundaries between each city. So for the most part we call everything outside of the Vancouver City borders as the "suburbs".

Select as Best AnswerUndo Best Answer

user
kelseymh (author)canucksgirl2012-01-11

I've been to pretty much all of those places except "POCO"(?) ... Oh, thank you Wikipedia! We've been to Port Coquitlam as well. I was curious because I learned several great "Surrey jokes", but didn't want to offend ;->

Have you ever been to Los Angeles and driven around? The only way to tell when you go from one city to the next is that the street signs change color, and sometimes the addresses start counting over from "1".

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)kelseymh2012-01-12

LOL... Sorry got lazy and wrote POCO... good thing there's Wiki. :D - I'm not originally from the Lower Mainland (aka GVRD), so ya, I've heard ALL the Surrey jokes... thankfully the new mayor has been cleaning up the city and since housing prices went up there are much less "riff raffs" around.

I've only made it as far as the Bay Area, but I get what you mean about the boundaries. You wouldn't know you changed areas unless you look at the signs.

We've been growing up so much here that I imagine the Lower Mainland and Fraser Valley will soon do the "merge". They are already so close that with only a little development, there'll be no way to tell the difference from one region to the other.

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)canucksgirl2012-01-11

I hope the irony isn't lost regarding the fact I'm reporting a "bug" on the "bug" page. :D

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)canucksgirl2012-01-11

Oh, I forgot. Here are the screenshots in case you needed them.

Select as Best AnswerUndo Best Answer

user
monsterlego (author)canucksgirl2012-01-11

Dear me I'm having the same issue.

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)monsterlego2012-01-11

Ya, it seems to be a bigger issue. I got an email back and they are working on it.

Select as Best AnswerUndo Best Answer

user
sunshiine (author)2012-01-11

Reporting a reply to comment bug:
I hit the reply button on 2 of my comments and do not get a reply box to input text. I don't get please refresh your page or any message from the program. It simply does nothing as if the page froze up. However the page is fine. I went to a different Instructable on my page and I could not reply to any of the comments either. I hope I explained this well enough. Thanks for reading!
Sunshiine

Select as Best AnswerUndo Best Answer

user
canucksgirl (author)sunshiine2012-01-11

I've had the same issue on and off all day. I hope they were aware of it?

What I had to do each time was reload the page, then the comment box would work. There's been a few "growing pains" on the site since it went down for an update last night. (I'm assuming that's what they did. The site said they were "moving furniture"). LOL

Select as Best AnswerUndo Best Answer

user
Goodhart (author)canucksgirl2012-01-11

I see that sometimes and a page refresh/reload sometimes helps

Select as Best AnswerUndo Best Answer

user
sunshiine (author)2012-01-11

OK guys this is weird:
I came back here to report that I commented on 2 members Instructables and the comment went through fine. So I came to this page to comment under my bug report about the comment button and tried to reply and the comment box would not load. I then tried to make a new comment and could not get a box. So I logged out and tried again and this box showed up. Let see if it will work.

Select as Best AnswerUndo Best Answer

user
boomfiziks (author)2012-01-08

I've been trying to upload my video instructable all day today, but keep running into the same problem. As you've requested, I've made some screenshots and attached them into a word document.

I've been using Windows XP while using Chrome, IE ver.8, and Firefox. I've also tried using our Mac that runs iOS X while using Safari and Firefox.

Typically, it keeps asking me to refesh the page, but if it doesn't, then the "updating" bar remains and I've allowed it to run for several hours, but never progressed from there.

I would really like to get my video posted for one of the competitions and I'm running out of time. I've put a lot of hard work (as I'm sure many others have also) into preparing their instructables.

Can someone please help or have some other means to post our video instructables.

Thanks!
Dwight

Select as Best AnswerUndo Best Answer

user
boomfiziks (author)boomfiziks2012-01-09

Got a new error message when it was trying to update. I still haven't had any luck with the "edit". It still runs continuously or states that to refresh the screen.

I'm using a different Dell computer which has Windows XP and have tried using IE 8 and Chrome. This computer is linked to the Internet with a T1/fiber optic line.

Select as Best AnswerUndo Best Answer

user
boomfiziks (author)boomfiziks2012-01-09

After many failed attempts, I think I finally have my instructable submitted. A problem I now have is that it shows I have 2 submitted instructables, but only one of them works. Is there a way to delete the non-functioning one? When I try to click on the "edit", it shows the "updating" with the scrolling bar, but it never goes beyond that point.

Select as Best AnswerUndo Best Answer

user
sherrycayheyhey (author)2012-01-09

If you have a list of bugs to work on this should probably go at the very very bottom of that list but there seems to be an issue with the dollar sign $ when using the search bar. When I search for my most recent project, $tars, a few of the results show up as 'tars' but when I click the link the correct '$tars' title shows up on the actual project steps pages.

I'm guess it has something to do with being a special character. I'm not sure if the $ is dropped off when used in the middle or at the end of the word and this may be something to check out. Also I'm using Mac OS X, Version 10.7.2 and Safari 5.1.2.

Attached are two screen shots that show 'tars' and the correct '$tars' page that it leads to.

Select as Best AnswerUndo Best Answer

user
Invention Co. (author)2012-01-02

Lately I have been on the move so I try to go on instructables on my iPod every time I get wifi, such as if I stop at Dunkin Donuts. But when I try to login, the box just keeps jumping around the screen and it's hard I see what your typing in and it's hard to even login. I have the latest os and updated the iPod barely a month ago. And I'm using safari... But I don't think that helps much. Sorry ill add pictures when I get home, I'm currently on my Ipad. Also as a good ad on you guys should make a add pictures button for mobile devices. That would help allot I would suggest.

Select as Best AnswerUndo Best Answer

user
cmcgann (author)Invention Co.2012-01-02

I have noticed this same thing with my iPod.

Select as Best AnswerUndo Best Answer

user
cmcgann (author)Invention Co.2012-01-08

Yes. I am constantly on the move, as a student of theatre sound. I will try and post some screenshots soon.

Select as Best AnswerUndo Best Answer

user
ebayboy98 (author)2012-01-08

Your mobile site does not function correctly. I have an Ipod touch 4th genoration and running safari. it has no problems and running IOS 5.01 when I search something it just brings up descusion forms. Also when I finally get the search to work then the pics dont come up. When i log in as my acount as soon as i search something it logs me off my account. It happens every time i search the instructables mobile website i always have to switch to full site. I have talked to my cousin and it does the same thing for him (but sadley he is not a member) To me all of this are bugs!

Select as Best AnswerUndo Best Answer

user
bfk (author)2012-01-07

This may be an issue at my end, but as of late, whenever I make an edit to one of my instructables, the "Intro" text field goes blank. I've gotten into the habit of copying and pasting my intro text to get around this, but it is frustrating.

If it's me, please let me know. Thanks.

Select as Best AnswerUndo Best Answer

user
Irock148 (author)2012-01-07

the problem i always get is when i go to the 7th or 8th page of a search, go to an instructable , but when i go back to search it brings back the first page of results instead of the 7th or8th. i am not aware if this is a bug or not. please tell me if u fix the problem

Select as Best AnswerUndo Best Answer

user
FrozenIce (author)2012-01-02

u guys posted domething on ur facebook page, about uploadinf a photo of a 5 sided paper star and ofering 3 months pro membership for it, and i did as asked and got nothing : \ i was quite dissapointed by this false offer.

Select as Best AnswerUndo Best Answer

user
caitlinsdad (author)FrozenIce2012-01-02

Do you have a link to the original offer on facebook to see what that was? And a link to where you posted your pic? I don't do facebook so I would be interested in what those rogue marketeers are up to.

Select as Best AnswerUndo Best Answer

user
FrozenIce (author)caitlinsdad2012-01-07

apperently, they wanted us to upload it on to the instructables fb page, not just upload it anywere... woops..

Select as Best AnswerUndo Best Answer

user
GASSYPOOTS (author)2012-01-06

when i am posting comments the sometimes dissapear without being deleted as if they were never there...

Select as Best AnswerUndo Best Answer

user
zjschafer (author)2011-12-31

Im trying to make a video instructable, but everytime I go back to edit the unpublished video, the updating files pops up then an error message appears and I have to refresh the page. REPEATS.. over and over again. By the way it doesn't recognize my instructable as unpublished- like a ghost file or something and next to the word unpublished, it has the number (0) when ever I obviously have (1) instructable in it.

I also would like to say that you cant start a new instructable after this glitch occurs, and you cant delete the unpublished video instructable yourself. You have to ask a manager at instructables.com to delete it for you. THIS IS A HUGE BUG, the creator of their own instructables should be able to manage themselves.

I would like this to get fixed as soon as possible please. Thankyou!

Select as Best AnswerUndo Best Answer

user
zjschafer (author)zjschafer2011-12-31

Heres a screenshot of it. I circled the updating and error messages.

Select as Best AnswerUndo Best Answer

user
highvoltageguy (author)zjschafer2012-01-03

That happened to me as well!

Select as Best AnswerUndo Best Answer