Author Options:

Special Characters " ' & $ etc changing to Klingonese “ Answered

Why are the special characters in my Instructional changing to some form of computer code?


I use linux, so I can't much relate here, but copy paste is generally better on this side... However, Word isn't a pure-text (ASCII only, no special formatting formats!) editor, and notepad/wordpad are. The "Klingonese" characters you're seeing are the computer trying to put non-pure-text text into pure-text, and it's getting messed up because pure-text doesn't use the formatting of Word. Yall following me?

NachoMahma is right. It's a problem with your word processor. I've seen this problem before. There isn't a way around the font issue, you just have to use the font that's here. Google 'TextPad' and get the text editor and install it on your Windows machine. If you're on linux, you can use 'Kate' its probably already installed. I don't know about a comparable text editor for Mac TextPad is a hotrod compared to notepad and has spellcheck and lots of other features. That'll do the trick.

. Most word processors have a "Use curly quotes" (or some similar wording) option. Turn it off.

Ok, so I now have the key to this issue from a member but I need to paste it here for you all. noahw says: Those weird characters are caused by copying and pasting text from strange sources into the Insructables editor. Sometimes ' and " which are curly cause it (the ones I just typed are straight). If you'd like to fix the problem, paste the text into a text editor first as plain text, verify that you don't have any strange characters, and then paste into the editor. That should help. Or, simply type directly into the editor. arcticpenguin says: Tried your suggestion and you got it. I put together a few words to test various things with results as shown. typed directly It's wouldn't can't "hello" copy from Wordpad It's wouldn't can't "hello" copy from Word It’s wouldn’t can’t “hello” Then I tried different fonts some with curly and some not curly. None worked though. Times New Roman It’s wouldn’t can’t “hello” Arial It’s wouldn’t can’t “hello” Book Antiqua It’s wouldn’t can’t “hello” Comic It’s wouldn’t can’t “hello” Trebuchet It’s wouldn’t can’t “hello” Microsoft It’s wouldn’t can’t “hello” So it looks like I need to work this out as I used wordperfect to spell/grammer check. Many thanks to all on this. Hopefully others will find it helpful too.


10 years ago

Like these?««ëà█Ç They're called alt codes.

Ok, but how do I get correct for them in my future projects. Is there some code I need to enter instead of the special characters like " ' etc Thanks

Because the Instructable Robot is a digital eejit. As things stand, the only way round it is to use similar characters from the standard set. Dollar signs are fine, if you wan to talk about cash from the UK, you need to call them "GBP". Accents and what-not, forget it.

But surely the word - it's - should not look like this It’s


I'd report that as a bug - it's "submit feedback" in the menus at the top of the screen.

Did that and am awaiting comment. Worst part is I had to go back and 'debug' all 12 pages of my instructable. I just don't (again don't wouldn't work) understand how this has not come up yet. Even tried to eliminate the font/character set potential issue as scorhr mentioned by copy from MSword and paste to wordpad and then cut from wordpad and paste to the Description box in edit Indestructable. With same results. Thanks