Author Options:

custom computer build problems with PCI expansion slots? help please! Answered

my build is:

ASrock z77 extreme4 mobo
Intel core i5 3570K CPU
GEIL 8GB (4x2) dual channel DDR3 ram
old Samsung HDD (i plan to change this out soon)
Ubuntu 12.10 64 bit (and 12.04 32 bit on dvd)

old d-link WDA-1320 PCI WiFi card
TV/FM winTV-HVR-1600 (also PCI)

whenever i plug the WiFi card or TV tuner into the PC slot, the motherboard does not recognize it. (system browser inside the BIOS) this it getting annoying since i don't have WiFi and don't like using my old usb adapter  not to mention the TV (however i think the tuner is shot, not working, it only crashes Ubuntu when it is installed.)

i don't know if this something misconfigured or something wrong with the mobo. i recently have been have problems with what i think is my HDD going bad, where Ubuntu crashes and need a fresh install i do have a 1 year extended warenty i bought from newegg to go along with the mobo. i don't have anything to plug into the other slots so i cant test them to see if they are working.



5 years ago

i think i am just going to get it fixed/replaced under warrantee.

Have had a similar problem in that the 64bit version of 12.10 is NFG, uninstall a go with the 32bit i386 version instead, Also go to the mobo's support site and determine if Linux is Bios supported as not all manufacturers even consider building in support for Linux on what is considered a gaming mobo.

Good Luck


but would this explain why the BIOS doesn't detect the PCI cards?

it would make sense because last i remember it working i was using 32 bit Ubuntu, but a lot has happened between that time.

go with 32 bit to confirm,or spend some time on the Ubuntu forums for some more insite.

good luck

that didn't help. i am running a fresh install of Ubuntu 12.04 32 bit. now i know that it is something other than the OS.

like i said, not even the BIOS recognized anything in the PCI slots, and im sure that at least one of the three (modem, tuner, WiFi) cards work

Have you tried the cards in the other slots? Is this a fresh Ubuntu install with the new system or did you try to use an install that was already on the HDD? If it isn't a fresh install then I would highly recommend doing that as it's going to have a hell of a time working out the drivers if it was plugged into a different system.

fresh install. there are only 2 PCI sots, i tried many combinations, neither CPI slot seems responsive in the BIOS system browser. (it shows a picture of the mobo and highlights the area that something is plugged into. it used to show the cards plugged in, not it says its empty.)

Have you installed the drivers for the cards?

there is no need to with the wifi card because it worked before, but now it doesnt. I have the unify bios, that has a system browser that shows a picture of the mobo and it used to show things in the PCI slot but now it shows they are empty. I cleared the CMOS but th did not help.