Author Options:

error code? Answered

I got the blink to work last night but tried again this morning and I got the following error code:

It blinks but I couldn't change the delays

Arduino: 1.6.7 (Mac OS X), Board: "Arduino/Genuino Uno"

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "COM1": No such file or directory
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#up... for suggestions.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

2 Replies

bekathwiaBest Answer (author)2017-06-06

Hmm, have you tried any of the steps on the Arduino troubleshooting page? https://www.arduino.cc/en/Guide/Troubleshooting#up...

Seems like your computer can't see your Arduino board. I'd first try a different USB port and/or cable, and restarting the computer and Arduino software. Make sure the correct port is selected before uploading.

Select as Best AnswerUndo Best Answer

paulhschulman (author)bekathwia2017-06-06

The problem was I had to identify the port. Once that was done, no problem.

Select as Best AnswerUndo Best Answer