1216Views7Replies

Author Options:

Measuring the piezo transducer with oscilloscope Answered

Hi,
I am conecting a piezo disc as a microphone to pick up vibrations.
.The problemm is when I measure the signal with osciloscope I am getting a messy and modified one with many noise 
If I am measuring it with PC oscilloscope (threw the sound card mic input) I am gatting a clean desirable signal
What is the true signal and what I am doing bad with the oscilloscope.
Thanks!
Anna

Discussions

0
None
gmoon

4 years ago

Piezo transducers have a very high output impedance, typically over 10 Megaohms. For comparison, guitar pickups are usually categorized as "high impedance" audio outputs and they generally run 3K-15K ohms, much lower than piezo devices (7000 ohms vs. 10,000,000 ohms). Your 'scope may have a lower input impedance than the PC input, which effects it's performance, in this case.

High impedance output devices tend to be inherently noisier, also.

High output impedance devices generally call for an even higher input impedance on the next stage, or signal is lost. You could use an opamp to buffer the disk.

0
None
Downunder35m

4 years ago

Your scope might pick up on interference through the cables.
Try to connect the probes as direct as possible to the piezo.
Could also be wrong use of the scope altogether, no idea without more info...

0
None
AnnaL3Downunder35m

Reply 4 years ago

Thanks.

Wrong use is my worry too... but I don`t know what exactly wrong

0
None
Downunder35mAnnaL3

Reply 4 years ago

Filters, probe settings, calibration, wrong timebase or voltage selected....

0
None
AnnaL3Downunder35m

Reply 4 years ago

Think found it.... Wrong connections....

0
None
Downunder35mAnnaL3

Reply 4 years ago

Well, we never stop learning...
So the scope is now showing proper results?

0
None
AnnaL3Downunder35m

Reply 4 years ago

Not the expected but real results:) no the one I want to see but real is good:)