54Views5Replies

Author Options:

Win8.1 Lost Plug & Play ? Answered

I am using WIN 8.1 and recently purchased a USB 2.0 SATA 2.5" HD HDD Hard Disk Drive Enclosure External Case Box and it stopped working. It may be due to losing my Plug and Play software and does not recognize the attachment. I am also using FireFox  and MS IE. I would appreciate your help assisting the input in restoring my Plug and Play. Thanks for the site it is a great assist.

Discussions

0
None
mpilchfamily

5 years ago

Does the system recognize other USB devices. If you unplug your mouse and plug it back in does it still work? If so it's not a plug and play issue. It would be a problem with the Enclosure's USB interface. In which case you should return the encosure and get another one.

0
None
mjp88keysmpilchfamily

Answer 5 years ago

I can't unplug the mouse, it is internally installed on my laptop. But I will try your suggestions. I really appreciate your assistance and I think this site is great for someone out there to give ideas as to where to go and how to possibly fix problems. Thanks again for your input.

0
None
mpilchfamilymjp88keys

Answer 5 years ago

You get the idea. Try other USB devices to help rule out a problem with your laptop's USB interface. Plug and play is built into the OS and not something you can easily delete from the system. Chances are the enclosure has fialed you.

0
None
mjp88keysmpilchfamily

Answer 5 years ago

Really appreciate you input, great site. Thanks again for your assistance.

0
None
mjp88keys

5 years ago

Great that people take the time to give recommendations. Great site.