Search for URL in Topics

I need to change my instructable URL urgently

URGENT: How can I get the URL of my instructable changed? It got shortened to first I thought the ending was just annoyingly funny. But ironically I am a teacher, and the school server blocks it, because it says "Meth"! Hilarious and not at all funny. : <I've tried changing the instructable name, but the URL is apparently already set and indexed, so it requires someone official to change it. Pleeeze!

Topic by mobilerik    |  last reply

URLs are now text!!!

A couple of changes to the site. URLs are now human-readable. So you can go to and not it a lot easier, eh?Also, Not Liable is now Offbeat blog post

Topic by fungus amungus    |  last reply

Instructable URL incorrect

When saving my recent instructable, one of the pages, specifically the parts list, was lost.. I re-entered the data, but somewhere in the process the default URL for my project became:  which is obviously not the title of my build.  It will also title any printed PDF's as Parts Needed. Is it possible to rename this URL appropriately, as in: Thank you.

Topic by DerekMellott    |  last reply

HTML URL icon?

How can I put an image in the URL and/or title of a HTML page? I am trying to make a website and would like to have a little image on it.

Question by tzq33tdq    |  last reply

Adding a URL into a comment

Thanks for sorting it out where if you highlighted some text in a comment/topic/i'Ble and used the link button to create a link it would duplicate the text. While it may be old news I've just recently noticed. It's great!

Topic by ll.13  

Question about URLs Answered

How come some instructables are "" and some are "" P.S. neither of those are actually links. I know how many of you clicked on them.

Question by kcls    |  last reply

getting a location from urls

Does anyone know how to find where an url is from.I dont need details but a country is fine. I have been looking at viewable cameras but the never say where they are from, just the url.

Topic by maninamousesuit    |  last reply

Instructable not found? URL invalid?

Hello, I posted an Instructable last night where the URL won't resolve for anyone else. It will resolve for me on Chrome, probably because it is cached? But when I try Chrome on another machine it won't resolve. None of my friends could view it, and when I tried the URL in Firefox and in IE (and Chrome on a different machine), it says: "Sorry, we just can't find that one! -   We're sorry, the URL is either incorrect or no longer available. Maybe you are looking for one of the following Instructables below." Then my Instructable is the first picture result that shows up under that error message, but clicking on the picture does the same thing. In my personal area the Instructable is there and listed as published. Thank you very much, Misty

Topic by mistyp    |  last reply

URLs in newsletter for non-HTML readers

Hi, just thought you would like to know ... I receive the frequent Instructables newsletters.  However, I read mail in "mutt", a terminal-based text-only email program.  If I want to follow a link in a message, I cut-and-paste it from the terminal to a browser. The URLs in the Instructables newsletters are ludicrously long, which makes them a chore to cut-and-paste.  One I wanted to access today was 740 characters.  I don't know of any compelling reasons for a URL to be that long.  (I'm sure there are "reasons", I just suspect the same goals could be accomplished with URLs less than 100 characters long). I'm sure I'm in the extreme minority here, so I don't expect anyone to rush to fix this, but just thought you would like to know at least one newsletter recipient almost never follows the links it contains. Sorry if this was not the appropriate place to post this.  A quick scan of the site did not turn up a "feedback to Instructables" option. Thanks, Mark

Topic by abqcheeks    |  last reply

Can't save profile website url with https://

Hi, I'm trying to add a profile URL at the settings page. Our website is https only, but if I add an URL starting with "https://", then after save the "http://" part will be added to the front of the URL, resulting in something like "http://". Attached screenshot after saving. I don't think it's a system issue, but anyways, same experience both with Firefox 39.0 and Chromium 44.0.2403.107, on Arch Linux 64-bit. The problem is at on the Settings tab. Cheers!

Topic by taipeihackerspace    |  last reply

Easy-to-remember names!

Ever wanted to share your instructable with someone offline? Its hard to remember those random ID's at the end of the URL, isn't it?HAVE NO FEAR, I AM HERE!(Note, you can be afraid of me, if you'd like)Anyway, on to the point.Biobattery!Look at the URL! Its all nice-looking! And what do you know, I added the Allsteps link in for you!You probably want this for yourself, dontcha? Don't worry! Just type this in the URL of your favorite browser! "slug" is the thing that goes on the end of the URL, in the above case, it was "biobattery". It can be numbers or letters, but it is case-sensitive!The instructable ID should be JUST that random string. No slashes, no ?ALLSTEPS, just the random letters/numbers.Please, please don't abuse this, please. If I find that someones been taking up multiple slugs for an instructable, or not linking to an instructable, you're going to be sorry ;-)All of you who say I should being doing something else, this was done in less than fifteen lines of python! Thats why theres no nice page to create those links, because I'd have to spend 10 minutes making it. I actually spent more time on this post than getting it to work!And if anyone wants to donate a nicer domain, just ping the above domain to get my IP, and let us know ;-)PS: If you hate "", you can use "", if you can remember it! Its pointed at the same server.

Topic by zachninme    |  last reply

Incorrect contest link on first page.

The link on the front page to the survival contest has an extra com/ in it. I've copied and pasted it below. Thanks.

Topic by Snibril    |  last reply

How to include a URL without a hyperlink?

I'm writing an instructable where I include some Linux wget commands that include a URL as part of the command. (i.e. wget The instructables editor automatically converts the URLs to links with anchor tags.  Is there a way I have the editor not convert the URL to a link? 

Topic by talk2bruce    |  last reply

if you want a video instructable does it have to have a URL? Answered

I wanted to make a video instructable but dont know if it needs to have a URL. Any help?

Question by EPL    |  last reply

New I'ble single-step URLs are broken for steps 10 and later

As Jamalam posted this morning, a new bug was introduced with the overnight feature rollout.  For published Instructables, the individual steps now have human-readable URLs of the form "" (e.g., "").  This is really nice. Unfortunately, the server-side code which generates these URLs is buggy.  For two-digit steps (step10 and higher), the URL does not resolve correctly, reverting back to the intro step.  You'll see this if you follow the link above.

Topic by kelseymh    |  last reply

How did some groups get URLs different from their titles?

I have run across a few groups so far ( Kids in Science and Engineering, Grammar Police, and some others) where the Instructables directory name in their URL (i.e., www.../groups/XYZ) is not simply a slightly-mangled version of the title (space -> _, etc.).I'm curious how this was done. Did an earlier version of the Instructables interface allow creators to specify both a title and a "shortname"? Or did the Staff intervene manually in special cases?

Topic by kelseymh    |  last reply

Can you fix my Java code?

I have this. import javax.swing.JLabel; import; import; import; import javax.swing.JFrame; public class WebViewer {   public static void main(String[] argv) throws Exception    {     URL url = new URL("");     BufferedReader in = new BufferedReader(new InputStreamReader(url.openStream()));     String str;     while ((str = in.readLine()) != null)     {       System.out.println(str);       JLabel textLabel = new JLabel(str); }     }   } I'm getting an error that says Exception in thread "main" Server returned HTTP response code: 403 for URL:     at     at     at WebViewer.main( The code should be getting a url's content and printing it to the screen. I'm using youtube as a test. Can you help me?

Question by 4lifenerdfighter  

Maintain permanent link to my instructable? Answered

I'm confident my instructable-to-be will need changes and additions after I publish. As I understand it, such changes may require changing the i'ble's url. But, I expect to publicize the url (on paper, even) and want it to have a long lifetime.Is there any help within My fallback: find if tinyurl or a similar site will let me establish, then later re-point a tiny url to the new i'ble url.My second fallback: publicize only "as seen in" and hope that someone searching on the project's name, "memorable name goes here", will find it.===== "Select a category"? Give me "questions" or "answers" or "process" as a choice, please!

Question by Larry Breed    |  last reply

Feature Request: Anchors in TOS

. It would be nice to be able to point directly to sections and sub-sections of the TOS via URL anchors. Ie, would jump to section 8a.. Yeah. I'd call this real low priority, too. :)

Topic by NachoMahma    |  last reply


I was looking at Evil Mad Scientists website (following the link Patrik provided on (this)i'ble..) anyway back on topic: I noticed they had the bottom of the page was: "Trackback URL for this entry:'s what others have to say about 'How to make a Sawed-off USB Key':" Then with links of site that had linked too them. 'twas thinking it'd be pretty cool if it can be implemented into Instructables somewhere/somehow. =)

Topic by ll.13    |  last reply can't login to the site using IE10

There is an issue where IE10 and above users cannot log in to, due to the cache headers sent to IE with the URL redirection response. To reproduce, simply navigate to and attempt to log in using IE10. Notice nothing happens upon submitting credentials. The issue is upon redirection to;=/id/edit. This redirection response is sometimes sent with a Cache Header, ( with Cache-control:private, max-age:86400) and sometimes is sent with Cache-control:no-cache, in which case it works correctly. So wininet caches it, since in urlmon we set INTERNET_OPTION-ENABLE_REDIRECT_CACHE_READ. Now, when we enter credentials and login, we again try to get to with the right cookies. But since we have cached the redirect, instead of resending HTTP request we again end up on the login page.  

Topic by IECompat  

Account Featujre Request: Download Instructable Favorites to Browser

I would love to see some additional functionality added to Instructable's Favorites system if possible. 1. the ability to download your Instructables favorite's list to either a browser or text file.  2. The ability to view Instructables favorites as a list 3. a search command that allows one to search through Instructables Favorites rather than the whole site. I believe these additions would make for a better experience and make Instructables a more robust tool and resource. -Chris Tempe, AZ

Topic by OgreHacker    |  last reply

Open link in new tab broken. (gets replaced by rel = "nofollow")

Hello, I like it when links open in a new tab. And I have lots of links in my new instructable, so I want them to open in a new tab or window. So, I tried to use the check icon you can see when you edit a link. I make sure I save my alteration. Then, I go check it out in the preview. (the preview you get when you click on the title in your drafts) And I see the link there, I click it, but it doesn't open in a new tab. Then, I press "edit" to see what went wrong, I check the link editor and see that the checkbox is not checked anymore. So, I thought, this checkbox is broken, I'll just do it in the code. I locate the link in the code: (And I notice the weird rel="nofollow") I change it to "target="_blank"" which should do the trick to open the link in a new tab.  I make sure that I save my alteration again. I check my link again in the preview editor and alas, I see again that my link opens in the same window. And I check the source code as provided by my browser (via the "inspect element" thingie in firefox) and I see again that that "rel="nofollow"" is back again. I've googled, and found that that probably is something to prevent bots from opening those links. A security measure? Is it possible to re-enable links to open in new tabs? Thank you!

Topic by Sparticles  

RSS feed source URL

It seems like if this topic has been left over the last years, but I´m still looking for an rss feed source URL that passes the test on the W3C Feed Validation Service.I´m trying to show all instructables with a specific keyword on my own website (using a WordPress plugin like RSS Aggregator).Any idea someone?

Question by koen.michiels12    |  last reply

The "/tag:user" URL fragment is not working

It would appear that the "/tag:user" filter in I'bles URLs is broken.  You can't search for usernames, you can't pull up a list of recently joined users, and so on.  Is this intentional?  Is it a known but low priority bug?

Topic by kelseymh    |  last reply

Highlights section, bad url for the Hydroponics channel

Highlights section, bad url for the h hhttp??? until fixed, just get rid of the extra H this is site wide, but occurred on   among other pages

Topic by leesha_kajira    |  last reply

Somewhat misleading link for bug reports on Submit page

I think that the link for "Submit new Bug Report" on the main Submit page is a bit misleading, especially to inexperienced users.  Instead of going directly to a page for creating a new forum topic in bugs (i.e.,;=help&category;=bugs) the URL associated with that button just goes to the top-level Help forums list. I'd like to suggest that the URL be changed.

Topic by kelseymh    |  last reply

Bad Links In Newsletter

I have been getting the message: "The URL is not syntactically valid" for all the links in your e-mails since the January 24, 2013 newsletter. I was & am using Eudora 6.2.4 on a Mac mini OS 10.4.11. The links in the January 17, 2013 newsletter, & all previous newsletters, did & still do work just fine. What changed?     Sincerely,     ~ Wolfwerx ~

Topic by Wolfwerx    |  last reply

Link procedure does not work

When trying to add links in my instructables, the link procedure does not work. I have tried everything, talked with Sarah on line, seen others solutions, gone to forum and looked at the same issue.....I assumed it was my computer, but if others have had the same issue, and there is a bug, it's not my computer. so....What PRECISELY goes in "Link URL:"? Your example says:, do you put brackets before and after? do you type it EXACTLY as shown? I think I have done both and it doesn't work. Oh, and this message body box, when clicking on link, doesn't show the Link Name. Is link name the name of the instructable I want to link to? Is it case sensitive? can you cut and paste? Cman

Topic by Creativeman    |  last reply

Why don't old /community/* urls redirect to new /topics/* urls????

All of the older links to a topics on Instructables link to urls, but a while ago (I'm not sure exactly when) all the /community/* pages were moved to /topics/*. Clicking the old /community links returns a 404 error, which is annoying because then I have to manually replace the "community" with "topics" in the url. So my question is, why can't all the /community/*/ pages redirect to their respective /topics/*/ pages?

Topic by scitronboy  

Why couldn't I enter in this url - http://your.raspberrypi.ip.address:5050

I need this url for making a echo. But it didn't work. Please help.

Topic by fairuj    |  last reply

Fixing a Typo?

It was late and I was typing away then I woke up with little sleep and posted my instructable.  Well, I had forgotten I wanted to change the title before I published then I fixed it.  Then my oh so brilliant self had a typo in the title, a helpful user pointed it out and I fixed it.  The problem? I don't mind that it has the original title so much as I mind the typo, LOL It's not a learing tool it's a learning tool.  Oi!  If anyone can help me out that would be great, if it can't be fixed, well I'm not going to get bent out of shape, it is what it is. Thanks in advance!

Topic by poofrabbit    |  last reply

What do you know about drones?

I would appreciate it if you leave a url or make a bib in MLA Starter (you can make one for free in noodletools)

Question by jamngary    |  last reply

Staff Pick Emails - Hotlink ALL items, not just the first one

I receive your emails and often find some of the items interesting.  Unfortunately, the only clickable item in the email is the predominate first item.  That's great, but I often find that I am more interested in one of the other items but when I attempt to click on them like I would in any email promoting "staff picks" or "featured items" - absolutely nothing happens.  Everything in the email should be readily clickable!  Please consider this simple and user-friendly change.

Topic by theojt    |  last reply

what is this website's URL and date of access?

The URL of this website and date of access

Question    |  last reply

Does every URL have a doppelganger? Answered

I lack the knowledge to frame this question properly, so here's an example of a website that has 2 urls for the same page: This shorter link: takes you to the same page as this longer link: Does every web page have a shorter URL?  If so, where can I find it? 

Question by bajablue    |  last reply

Twitter share button - error in url

Hi The url to update status on twitter is wrong. It's  "/#!/" in the url that should not be there.!/? The correct url for update twitter status is home detector /Marcus

Topic by _macke_    |  last reply

URL controlled led strip animation

Hi all,I need some help with a diy led strip projectI have 3 led strips (WS2812), Arduino mega, and an Ethernet shield (W5100).I want to mount the strips in our kitchen and control via a url.Eg. demo would kick off one of the FastLED example animation.My aim is to be able to choose different animations using urls sent via actiontiles (Samsung smartthings interface) and play a selected animation continuously until I select a different url.I can get it to play once but I can’t get it to play something else when I click a different url.I’m guessing my problem is my nested loops but I don’t have the skill or knowledge to be able to troubleshoot it. I suspect The url is jumping to a continuous loop and never exits it to see if a different url is selected... At least that’s my theoryAnyone care to start me off with an example of how to achieve this ?Arduino Mega,Ethernet shield (WS5100)Using FastLED.

Question by JasonK275    |  last reply

Does need a URL Shortener?

Hi everyone! Do you think needs a URL shortener that works like Just like YouTube has their shortener,, Instructables could have That way, instead of a URL like this... You could have this... Very handy for sharing your stuff on Twitter, Buzz, Bebo and Orkut. Cast your vote here.

Topic by Marsh    |  last reply

How do you look up Instructables Answers now without manually typing in the url?

Hello something is deeply wrong with instructables. you cant search instructables anymore, nor can you search questions, not without manually typing in the URL. what is going on? i dont understand how removing the buttons to allow us to view instructables or answers makes it more convenient, if anything i just see the site stripped down to its bones anyway, what is the new long route to finding the answers and instructables pages without typing in the address?

Question by oldmanbeefjerky    |  last reply

Messed Up URL!! Can it be fixed??? Help

Okay. So, I finished my first Instructable!! Then, I screwed up. I was on the last step when I published it & It put my last-step title in the URL & removed my Intro pictures!!!! If I click on the "See All" button, it shows correctly. I've tried to fix it but can't. The name (& Intro title) of the Instructable is: Arduino Ultrasonic "Parking Spotter", which should be in the URL. Instead, the URL is: "And One Sketch To Rule Them All" is the name of my last step! What can I do to get it to: I've tried UN-publishing it, but that didn't work. :( Help would be appreciated! Jeff (AptPupil)

Topic by AptPupil    |  last reply

Feature Request: Access to URLs of individual comments

There are many occasions where I want to cross-reference somebody's comment in another posting. Most of the time, I try to use the "date and time" stamp, but that's problematic since the time is computed on the fly in my local TZ. It's worse if the comment is embedded half a dozen layers down in some thread in a completely different Forum Topic. Once or twice, I've tried to use "View Source" in my browser, and search through to find the corresponding markup for the comment, and then extract the hash from one of the tag/JS attributes. Since the information is already there, would it be difficult to add a "link" hyperlink to each comments, such that the returned URL was the one needed to get back to that comment in the future?

Topic by kelseymh    |  last reply

USB Smart Button - change destination URL

I received a promotional USB Smart Button. I think it would be cool to change the programmed URL that it goes to when you press the button. A second idea would be to add a longer sequence of commands than just opening a web browser to a specific page. Anyone?Here is some info on the USB Smart Button... one site of many on a Google search. is a YouTube video of it in action. Scott

Topic by swcramer    |  last reply

Dagorhir sword materials?

Kay, I'm gonna build a [url=]Dagorhir[/url] blue-category sword. Thing is, the [url=]tutorial[/url] I've been following is kinda vague on the materials I need. What size PVC pipe do I use? Where do I get the foam? I just want a definitive list of supplies for the sword. Thanks, GearsOfAwesome

Question by GearsOfAwesome    |  last reply

Facebook connect doesn't work on Firefox (linux)

Hello, Facebook connect doesn't work on firefox 20.0.1. O.S: Archlinux, kernel version: 3.8.7-1-ARCH. It works on chromium 26.0.1410.63 (192696). Step to reproduce: from the main page, choose facebook login from the upper right corner. Nothing happens when I click on it. If I copy the URL in a new tab, at least I get an error from facebook: "Given URL is not permitted by the application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains."

Topic by davethecipo    |  last reply

Video submission glitch?

I'm new at posting video instructables.  In the required box that says "embed video code", does that mean the URL of the video that I have posted on Youtube, or something else?   When I enter the URL and click SAVE, it erases the URL.  I can't publish it without something in the video code box.  Help, please!

Topic by Thinkenstein    |  last reply

Annoyance: Formatting/URL mistakes suppress preview completely

A new feature deployed recently checks the URLs we put inside comments (i.e., the first token inside square brackets) and reports if we haven't given a valid URL.The annoying bug is that the whole preview is suppressed, and there is no indication of where in the text the error might be. Briefly, the preview actually showed the whole text, but with the error part called out in big red box. That was better, and would be nice to get back.Failing that, maybe just putting the malformed URL into the preview as a literal string, highlighted or underlined or something might be helpful.

Topic by kelseymh  



Question by anres321    |  last reply

User input not URL-encoded in the &quot;Ask a question&quot; input

On this page: There's the "enter your question" input box.  The user-input is added to the GET vars as "questionText", and the spaces are encoded as %20, but the ampersands and question marks are not.  This results in the question being split up & ignored, and the remainder is interpreted as another querystring var.  So typing in "What is this & that?" becomes "questionText=What%20is%20this%20&%20that?".  The ampersands & question marks (and all other non-URL safe) characters should be encoded. Thanks!

Topic by jumpfroggy