Search for js in Topics


Comments not working

Here is the error message that I caught User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB7.2; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; InfoPath.2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C) Timestamp: Fri, 2 Dec 2011 12:42:28 UTC Message: '0' is null or not an object Line: 6690 Char: 23 Code: 0URI: https://www.instructables.com/static/js/scripts.jsp?scripts=/static/js/prototype-ex.js,/static/js/us/scriptaculous.js,/static/js/us/builder.js,/static/js/us/effects.js,/static/js/login.js looks like it is related to the new logon update maybe

Topic by fjordcarver    |  last reply


Edit Images Profile/Images Not Working

Edit profile image and accessing available images in library are not currently working. Click and nothing happens From any URL it decides to land me on still get same issue https://www.instructables.com/member/MrRedBeard/?cb=1485832058 https://www.instructables.com/member/MrRedBeard/ Browser: Chrome Ver 55 OS: Win 10 HTTPS, but requested an insecure script 'https://www.instructables.com/static/drag_editor/deploy/uploader.html5.min.65.js'. This request has been blocked; the content must be served over HTTPS. In addition I'm getting Javascript Errors and Mixed Content Warnings http/https Uncaught ReferenceError: ibles is not defined     at child.showDesktopUploader (member-3461ed7a.js:2)     at Object. (member-3461ed7a.js:2)     at c (base-desktop-bs2-0e06bd33.js:2)     at Object.add [as done] (base-desktop-bs2-0e06bd33.js:2)     at Object.fetchUploaderScripts (base-desktop-bs2-0e06bd33.js:16)     at Array. (base-desktop-bs2-0e06bd33.js:16)     at c (base-desktop-bs2-0e06bd33.js:2)     at Object.add [as done] (base-desktop-bs2-0e06bd33.js:2)     at Object.fetchUploaderTemplates (base-desktop-bs2-0e06bd33.js:16)     at Object.fetchUploader (base-desktop-bs2-0e06bd33.js:16)

Topic by MrRedBeard  


-+-POSTED!-+- Jollex's Sniper, JS-144v3.9 =UPDATE=

It has been posted. Here is the link.UPDATEI added an extended barrel, because of The Jamalam's suggestion, and I weighed it and it is 1.6 Kilograms which equals ~ 3.5 pounds.UpdateI changed the mag and reinforced some parts.I have finally finished my awesome sniper. I have been planning this gun since June and started building about 2 weeks ago. It is the first of its kind. It uses a rail system like dsman195276's sniper but it has a mag. It has a lot of power and accuracy because of the low friction barrel made out of orange connectors and wheels. It has a trigger that I think is better than dsman's sniper trigger. It has a comfy handle that is like dsman's sniper handle. It has a comfy stock a very accurate and cool looking scope. It also has a sturdy bipod of my design and a comfy front hand grip. it is also easy to pull back the firing pin. the mag capacity is ~10. Mag reload time is ~8 seconds. Time to pull back firing pin and power transfer and fire is ~4 seconds. Here are some pictures.

Topic by jollex    |  last reply


Javascript Tic Tac Toe?

Hey guys... heres my code: var gameOver = false; var numMoves = 0; var xTurn = true; var computerTurn = false; function squareClicked(square) { if(gameOver) { alert("The game is already over."); return; } var status = document.getElementById('status'); var value = square.value; if(value != 'X' && value != 'O') { if(xTurn) { numMoves++; square.value = 'X'; xTurn = false; computerTurn = true; status.innerHTML = 'O\'s turn'; makeComputerMove(); } else if(computerTurn == true) { status.innerHTML = 'X\'s turn'; xTurn = true; computerTurn = false; numMoves++; square.value = 'O'; } } else { alert('That square has already been played.'); } var winner = checkWin(); if(winner == true) { if(numMoves == 9) { status.innerHTML = 'Tie Game!'; } else { gameOver = true; } } } function makeComputerMove() { var a0 = document.getElementById("0_0"); var a1 = document.getElementById("0_1"); var a2 = document.getElementById("0_2"); var a0 = document.getElementById("1_0"); var a1 = document.getElementById("1_1"); var a2 = document.getElementById("1_2"); var a0 = document.getElementById("2_0"); var a1 = document.getElementById("2_1"); var a2 = document.getElementById("2_2"); var got = false; while(got == false) { var n = Math.floor(Math.random()*9) switch(n) { case 0: { if(a0.value == " ") { squareClicked("0_0"); got = true; } break; } case 1: { if(a1.value == " ") { squareClicked("0_1"); got = true; } break; } case 2: { if(a2.value == " ") { squareClicked("0_2"); got = true; } break; } case 3: { if(b0.value == " ") { squareClicked("1_0"); got = true; } break; } case 4: { if(b1.value == " ") { squareClicked("1_1"); got = true; } break; } case 5: { if(b2.value == " ") { squareClicked("1_2"); got = true; } break; } case 6: { if(c0.value == " ") { squareClicked("2_0"); got = true; } break; } case 7: { if(c1.value == " ") { squareClicked("2_1"); got = true; } break; } case 8: { if(c2.value == " ") { squareClicked("2_2"); got = true; } break; } } } computerTurn = false; } function newgame() { var status = document.getElementById('status'); xTurn = true; status.innerHTML = 'X\'s turn'; gameOver = false; computerTurn = false; for(var x = 0; x < 3; x++) { for(var y = 0; y < 3; y++) { document.getElementById(x + '_' + y).value = ' '; } } } function checkWin() { var status = document.getElementById('status'); var val0; var val1; var val2; // check columns for(var y = 0; y < 3; y++) { val0 = document.getElementById('0_'+y).value; val1 = document.getElementById('1_'+y).value; val2 = document.getElementById('2_'+y).value; if(val0 == 'X' && val1 == 'X' && val2 == 'X') { status.innerHTML = "X WINS!"; return true; } else if(val0 == 'O' && val1 == 'O' && val2 == 'O') { status.innerHTML = "O WINS!"; return true; } } // check rows for(var x = 0; x < 3; x++) { val0 = document.getElementById(x + '_0').value; val1 = document.getElementById(x + '_1').value; val2 = document.getElementById(x + '_2').value; if(val0 == 'X' && val1 == 'X' && val2 == 'X') { status.innerHTML = "X WINS!"; return true; } else if(val0 == 'O' && val1 == 'O' && val2 == 'O') { status.innerHTML = "O WINS!"; return true; } } // check top left to lower right diagonal val0 = document.getElementById('0_0').value; val1 = document.getElementById('1_1').value; val2 = document.getElementById('2_2').value; if(val0 == 'X' && val1 == 'X' && val2 == 'X') { status.innerHTML = "X WINS!"; return true; } else if(val0 == 'O' && val1 == 'O' && val2 == 'O') { status.innerHTML = "O WINS!"; return true; } // check lower left to top right diagonal val0 = document.getElementById('2_0').value; val1 = document.getElementById('1_1').value; val2 = document.getElementById('0_2').value; if(val0 == 'X' && val1 == 'X' && val2 == 'X') { status.innerHTML = "X WINS!"; return true; } else if(val0 == 'O' && val1 == 'O' && val2 == 'O') { status.innerHTML = "O WINS!"; return true; } // no winner yet return false; } X's turn Any ideas on how to make it work? I think it has to do with the makeComputerMove function... so... yeah. I need your ideas on how to fix this. :)

Question by sci4me    |  last reply


Tessel: a new quick-prototyping microcontroller, programmable in JS

I haven't been very active on Instructables lately because I've been a part of starting a company (technical.io)! I thought the Instructables community would want to see: Tessel is an internet-connected microcontroller programmable in JavaScript that enables developers to extend the reach of the web to physical things. Since Tessel is compatible with Node.js and leverages the Node Package Manager, adding additional capabilities is as easy as plugging in a Tessel module and npm installing its firmware. Get Tessel and start making smart, internet connected devices! We have eight days left of crowdfunding: http://www.dragoninnovation.com/projects/22-tessel, so you can see our whole story there. Since Instructables still has a claim on my heart, you've got an open line to me if you have any questions. Miss you! Selkeymoonbeam

Topic by SelkeyMoonbeam  



Editor not working

I'm not able to open the editor. I get an error in the javascript console: Uncaught TypeError: Cannot read property 'Go' of undefined     at loadEditor (EEZ9RA7IPCYCPKA:1260)     at EEZ9RA7IPCYCPKA:1285 loadEditor @ EEZ9RA7IPCYCPKA:1260 (anonymous) @ EEZ9RA7IPCYCPKA:1285 Resources: https://www.instructables.com/static/drag_editor/deploy/editorcss.html5.min.56.css https://www.instructables.com/static/drag_editor/deploy/SCRIPT_MANIFEST.102.js https://www.instructables.com/static/drag_editor/deploy/editor.html5uploader.min.133.js all return 404 and I assume are required for the editor. Thanks

Topic by ncross1    |  last reply


Create Pages from JavaScript?

I was wondering if it is possible to create a text document from some JS embedded in a page. I know this may not be the perfect place to ask, but I might get some response : -) Thanks :-)

Topic by zachninme    |  last reply


Recaptcha Error: Cant Post anything

The recaptcha is not loading when I try to publish a new instructable. I'm using Google Chrome (v. 30.0.1599.101) on Windows 7. When I click on the Yes, Publish My Instructable button at the bottom of the publish page, it returns a "unmatching captcha values" error. The problem is that the captcha is not being displayed on the page. I did a bit of digging and it seems that the URL for the captcha script (http://api.recaptcha.net/js/recaptcha_ajax.js) is old and invalid, returning a 404 error. A quick google search reveals that the link above is indeed outdated and the updated link to should be something like http://google.com/recaptcha/api/js/recaptcha_ajax.js Kindly fix this asap.

Topic by nprasan    |  last reply


Express failed to fetch from registry in npm and node.js ?

Hello everyone  trying to make a node.js server and installing npm, expres, and serial port on Raspberry pi using the command sudo npm install express serialport  got these errors  any help ?

Question by HadirRashed1  


Stop the Everything bar from scrolling with the page

If you also dislike the Everything bar remaining visible (and eating screen space) as you scroll through pages of Instructables, open your favorite Ad Blocking software and add: https://www.instructables.com/static/js/ExploreView.js Once that's done, the Everything bar stays at the top of the page.

Topic by ringai    |  last reply


Practical uses for Python and JavaScript?

I was just wondering about the sort of things you can do with these two.  I know you can use at least JS when building webpages, but I don't really enjoy that sort of thing when I code.  Are there other uses for these?  Also, is it true that robots can be programmed with Python?  Thank you very much for an answer.

Question by StarscreamClone    |  last reply


Images and rollovers in Opera

Images often do not work in Opera, the little inline galleries per instructable don't work (can't click on images), and rollover tooltips for images don't work. JS error is thrown:message: Statement on line 3: Undefined variable: HelpBubbleBacktrace: Line 3 of inline#12 script in https://www.instructables.com/id/SRLH6Q1FK75CZBS/ new HelpBubble({Not sure about the gallery clickables, might be due to the erroring inline script.

Topic by delvarworld    |  last reply


Crashes my system to download the PDF

I have a Win 7 system with AMD processor.   I have tried two times to download a PDF and it crashes my system.  First time in years this has happened for me.  So what to do?   I am not interested to try for 3 times.  Is there a way to download without openning your window? Thanks, great site, JS

Topic by jhampa  


Busy script slowing down pages

The site is running slowly, and every time I change pages it takes an unusually long time for the page to load up, interrupted by this message pop-up: A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: https://www.instructables.com/static/js/prototype.js:5550

Topic by Kiteman    |  last reply


Can't flag comments as spam?

I tried flagging this user's comment as spam https://www.instructables.com/member/sohbetsiteleri/ Such as the one found here: https://www.instructables.com/id/Lasercut-Boxing-Kangaroo-Toys/ But I get a javascript error: "Uncaught ReferenceError: feedBack is not defined" in https://www.instructables.com/static/js/CommentControl.js Using Chrome browser on Windows 7. That's obviously a comment-spam-only account, so look at both of the comments.  The LED Throwie thread has got several spam comments.

Topic by Kozz    |  last reply


Characters removed from text.

I have received the following error on the old editor. "There's been a problem updating your Instructable parsererror SyntaxError: JSON.parse: unexpected end of data" I am using windows 8 and firefox 24.0 The new editor did not give me this error but instead removed characters (specifically plus signs) from my text. I believe the cause of the problem is that the characters I entered to show calculations needed for an instructable were messing up the JS parser. The instructable I am working on is in my drafts and called "how to make a 'cot' style hammock".

Topic by Todd Gehris    |  last reply


A-Jax - Speed - Web Developers

Why use slow flash when faster better ways are there? AJax is great, fast, and does the job. Here is some simple code for your site: xhr = (window.XMLHttpRequest) ? new XMLHttpRequest() : new ActiveXObject("Microsoft.xhr"); xhr.open("POST or GET", "PAGE-URI", 1); xhr.onreadystatechange = (function() { Code to run for the result.. }); Simple yes? My site uses the code above but within lots more Javascript hacks included. My site is http://sitegen.com.au/ My js file is minimized so to get to the code just goto http://sitegen.com.au/js.php?min=false and the same deal with my css file..

Topic by james.mcglashan  


Feature Request: Access to URLs of individual comments

There are many occasions where I want to cross-reference somebody's comment in another posting. Most of the time, I try to use the "date and time" stamp, but that's problematic since the time is computed on the fly in my local TZ. It's worse if the comment is embedded half a dozen layers down in some thread in a completely different Forum Topic. Once or twice, I've tried to use "View Source" in my browser, and search through to find the corresponding markup for the comment, and then extract the hash from one of the tag/JS attributes. Since the information is already there, would it be difficult to add a "link" hyperlink to each comments, such that the returned URL was the one needed to get back to that comment in the future?

Topic by kelseymh    |  last reply


Where to report crucial bugs?

Hey, I am posting this topic on the behalf of wanting to know where to directly report a crucial security bug to. This particular bug allows you to inject arbitrary JavaScript code into the site and thus gives you the possibility to do virtually anything, including, but not limited to, fetching cookies of other people and thus logging in as them etc. I reported all the other crucial bugs to service [at] instructables [dot] com and they got fixed after some time, but the issue with this one is that I reported it more than a year ago and re-reported and re-poked about it multiple times, still no fix present. So I wonder where I can contact somebody of the dev team directly so that this bug will actually get fixed!

Topic by Sorunome    |  last reply


What is the duration of Instructibles login sessions

Hello, I visit the Instructables website about 2-3 times per month (every 10 days or so), and it seems like EVERY time I do I need to login again. Even "Amazon" - and they're a commercial site - is better at "remembering me than Instructables. This is not actually a technical problem, but more of a question about Instructables policy (and also, it's a site complaint). (I can almost guarantee someone's going to misread my question so I'll say again... NOT a request for help. Yes I have cookies and JS on, and yes I'm using a good browser, Chrome.) It seems like I have to login every 4-7 days, possibly sooner, which is fracking annoying. If  there a better place to post site feedback, please be gentle, I did not find it before posting.  Thanks. (And despite my complaint, I love love love this website, it's in my top 5 favorites).

Topic by scottinnh    |  last reply


my websites cookies are being disabled by my dot.tk domain extension, will.com do the same thing?

Hello, currently i am making an online store for which i require cookies , soon i plan on giving my site a .com domain name, but for now im keeping it as .tk. however, after finnaly learning how to use cookies, i found my .tk extension somehow blocks cookies from being used by the website! is there a way to fix this? and when i buy a .com extension, will it do the same thing? heres a link to my testing site, without the .tk extension http://ombj.uphero.com/jpoopdog/testing%20site/cookie.html and here is a link to the site with the extension jpoopdog.tk click on the "testing site " link at the bottom of the page. the .tk url remains the same all throughout the site odly! all javascript used is on the pages themselves, and can be viewed via view page source in your web browser. i am not using any .js files for this, and do not wish to either.

Question by oldmanbeefjerky    |  last reply


Javascript bugs in FF and IE

I'm experiencing multiple bugs in Instructables, most JavaScript related. FF 11.0, have these same problems with FF10.2?. Instructables on safe list @ NoScript 1. Images look ok in instructables, switching between them in steps do not work at all. I click on the second image. It should replace the first one in the same container, nothing happens. 2. Can not vote. The stars are simply not there anymore. 3. There are 4 fingers white gap above, and 3 fingers white gap below the instructable title / photo-step row FF Javascript error console shows no errors. Things like Favoring/Unfavoring, commenting works fine. IE 8.0.6 1. Same problem as previous #1, yet clicking on the second image opens the image thumbnail directly in a new window. 2. IE displays "Errors on page" with this text: "Webpage error details User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322) Timestamp: Wed, 14 Mar 2012 13:18:56 UTC Message: 'f[...]' is null or not an object Line: 25 Char: 358 Code: 0 URI: https://www.instructables.com/static/js/gw-11.6.4/lib/gw.min.js I bet some script near the bottom of scripts is killing the rest of scripts, this is why some scripts work and some don't. Can provide more info if needed.

Topic by skiedra    |  last reply


This site's editor is the worst I have ever used…

This site's editor is the worst I have ever used… Once again, I have wasted my time in a frustrating effort to simply answer a question in my own Instructable, thanks to the still horrendous forum editor. Even after years of being online, and my and other people's utter frustration with this editor, it is still the worst forum editor on the web. Let me describe for you my current experience. First of all, I make it a point to compose my message in a text editor because I know from bad experience, that it is a certainty that the editor will lose all text that I enter at some point. OK, so I compose my message which contains some html anchor tags with links and text. I paste it into the text box. I hit the Preview button and nothing happens… Great. I see that NoScript (Firefox 30.0) is showing that there is some javascript that is not enabled. I temporarily enable JS. Poof! My text is gone!!! What did I tell you? I have to keep enabling JS several times to finally get rid of the red barred circle on the NoScript icon. I now re-paste my text that I thankfully still have safely saved in my text editor. Preview still doesn't work so I decide to switch to the Rich Editor. BTW I tried switching to Safari to see if it worked there and it didn't so it is not a browser issue. Now Preview works but all my html code is being shown as code and not nicely formatted text with embedded links. Wonderful. I have no intentions of wasting more time with the Rich Editor, trying to add links in the painfully slow process of point, click, copy, paste. No thanks… So I refresh the page. Poof! Text gone. I re-paste and simply click 'make comment' so I can PREVIEW my post. I need to make a few changes so I have to DELETE the post--there is no way to EDIT it like there is in any other forum I have ever used--and I have to repeat this ridiculous ritual several times to finally get it to the point where I can finally post the comment for real. Keep in mind, I could not use any formatting like bold or italics on any of the text like I wanted to do because there is no longer any markdown language. Formatting is only available in the Rich Editor which I refuse to use for reasons already mentioned. Oh, and one more thing… I tried to upload an image and the server was 'down for maintenance' so I gave up at that point. I was told that as a PRO member, the editor was an improved version of the normal one. I don't see any improvements. This and many other similar experiences I have had ONLY on this site, is IMO unacceptable. We all have a life and have much better things to do than waste hours of our own time struggling with an inferior editor in order to freely share our ideas with other people. This in itself is a creativity stifler. I have complained about this before and I probably will again until (IF) this problem is addressed properly. Obviously we the users are the life blood of this site and we deserve much better treatment. Once again, I make no apology for ranting and complaining--Kiteman. This crucial issue needs to be addressed. Get a new webmaster if that's what it takes. The current one is not doing his/her job. PS Wow, I had to preview this post before I could publish it and I see that all the breaks between paragraphs have been removed. Unbelievable. Even in an all-text post there are problems, which just serve to emphasize my point. PS 2 Wait a minute… When I went to edit the post and previewed it, the breaks suddenly miraculously appeared. So not only is the editor flakey, it is unpredictable as well.

Topic by Laral