949Views9Replies

Author Options:

Amp problems: Audio output cuts out on any bass.? Answered

I have a Sonic Impact T-Amp Gen 2. When running, the audio output suddenly cuts out on the bass of a song for half a second or so, and starts again. The blue LED light stay on however. There seems to be no connection between the times it cuts out, except for it usually runs for a while, at 50% < 100% of the volume. Can anyone help? Thanks.

Discussions

0
None
lemonie

Best Answer 10 years ago

What is it connected to - sounds like it might be cutting out to protect itself from overload? L

0
None
finnlaylemonie

Answer 10 years ago

It's a 12V 7aH battery, hooked up to the amp. It then provides 2x15W channels at 4Ohms, to one speaker in each channel, that are 4-8Ohm. It never used to do this when played full volume. I have however got new louder speakers. Do you think it could be this? Thanks

0
None
finnlayfinnlay

Answer 10 years ago

I tried it with the old speakers I never had a problem with, and they still keep cutting out. Any more theories? Thansk

0
None
lemoniefinnlay

Answer 10 years ago

What I could find doesn't suggest anything wrong as such, but if this started after you got new louder speakers, I'd suggest these are it. I.e. it is being overloaded at high volume and cutting out before it goes into smoke-machine mode...

L

0
None
finnlaylemonie

Answer 10 years ago

Yeah i must be that. Thanks.

0
None
steveastroukfinnlay

Answer 10 years ago

Check the voltage on your battery as it goes into peak load

0
None
NachoMahma

10 years ago

. I think lemonie is on the right track. Compare the amps rated output impedance with that of your speaker system. If you have more than one set of speakers hooked up, get rid of the extras.

0
None
DELETED_GuardianFox

10 years ago

Turn down the source device's volume to about half of what it is now. You're probably overdriving it.