Author Options:

Asus EeePC Charger Troubles Answered

First of all, I have to say I am sorry for posting so many forum topics. 
However, I often do need help from people like those found here - thank you all!

Now, with that out of the way, my problem. For christmas, I got an Asus EeePC. I am not sure of the specific model, but it is a Windows 7 Starter one. Anyway, a few weeks ago (I'm not sure specifically), the charger gave up and died on me. After checking the half that goes to the wall with another device, I realised that my problem lay in the adapter. I figured it was dead anyway, so no further harm could be done, and proceeded to hacksaw it open. Miraculously, after this, it worked. However, it is obviously not very convenient to have a charger that is constantly spilling its guts all over the place, so my mom bought me a new one off ebay. This one worked completely fine, except it was the wrong size plug for the laptop, so it had to constantly be anchored downwards. I decided to cut the two wires and connect the red to the red and the black to the black so I could have a normal adapter and the right sized plug. However, one of them did not have a red and a black but a white and an uncovered. After a short bit of research, I decided the positive was probably the white, so connected the white to the red and the uncovered to the black. However, when I plugged this in, it did not charge, and instead steam/smoke began to come from the laptop. I promptly disconnected and binned it. My mom bought a third one off ebay, which worked fine and fit fine, but when plugged into the laptop, did not charge it and the little indicator LED on the adapter flickered. So, for a third time, my mom bought a new charger off ebay. Again, this worked and fit fine, but when plugged into the laptop, did not charge it and flickered its LED. I tried this with various plugs from the wall (the figure-of-8 type), in various extensions, and straight into the wall socket, but all still to the same result.

Each charger came from a different person on ebay, and each (including the original and second which both worked) had an output of 19V 2.1A. I cannot figure out why neither of the latest two have worked.

Is my laptop broken? Am I somehow now buying the wrong chargers? Were the past two mere coincidences? Please help.

Thanks in advance, 




8 years ago

Did you screw up the battery? The smoke coming from the laptop indicates you may have fried something, blown a fuse or the power charging circuit. Does it work fine with the battery disconnected?


Reply 8 years ago

Thank you for the response.

Just tested without the battery... No luck :-(

Thanks again