Author Options:

CH340G and Standalone UNO R3 Got ERROR "avrdude.exe: stk500_getsync(): not in sync: resp=0x00?" Answered

I bough the CH340G USB-TTL with 6 pin (GND, CTS, VCC, TX, RX, DTR). The CH340 driver already installed, the arduino bootloader also already burn to ATmega328P-PU. When upload the sketch using FTDI or PL2303 or ATmega16U2 is okey and no error found. But if Ia using CH340 and connecteed below pin:

Arduino VCC ==> VCC CH340
Arduino GND ==> GND CH340
Arduino RX ==> TX CH340
Arduino TX ==> RX CH340
Arduino RESET ==> DTR CH340

The error always appear as "avrdude.exe: stk500_getsync(): not in sync: resp=0x00?" event the speed on the port setting already change at 9600; 19200 or 115200. Iam also trying with IDE 1.6.0, 1.0.5 and 022 the error message are same. May be someone can help me please?


The forums are retiring in 2021 and are now closed for new topics and comments.

5 years ago

Had the same massive problems with a Gen6 3D printer board.
Tried basically all Arduino ISP versions to no avail, was reading about 130 webpages of related error problems and still was clueless.
One thing I found messing with things was the SPI library.
In the sketch I downloaded the command "Include SPI.." was used and by default these SPI library files are all included with the IDE software.
But there was also a version of it included with the sketch and after removing the SPI folder from my IDE all was fine.
Then there is the problem with the boards itself...
Although you find the "right" Arduino base board in the list it does not always mean it works.
For the Gen6 board for example it was always mentioned to use the Sanguino board but only after finding an Arduinio IDE version that included a boar definition for the Gen6 directly I was a happy camper.
This is also where the big confusion comes from about what version of the IDE software to use.
Sometimes you might even find a download link with a sketch that is not the official IDE version.
Here the included libraries and definitions are matched to the board in use.
I downloaded some of them and only in one case I was able to select my Arduino Mega and it worked properly with the supplied IDE version.

After a lot of tries and even more errors I was able to narrow the worst causes of your (and at that time my) error message to the "fuses".
Let me try to explain:
To successfully flash a sketch or firmware you need to tell the Atmega ship that it has to overwrite / delete the existing code,
accept the new file and when done set all to the same lock status as before.
Here is bit of text from the "boards.txt" of an IDE version with just Sanguino support:


And here the corresponding section from a boards.txt with a dedicated Gen6 board section:

Generation_Series.name=Gen6 & Gen6 Deluxe

As you can see the fuse settings are different.
So although everyone on the web stated to use the Sanguino board for all programming needs it only works with the FUSE settings matching a Gen6 board.
I would say your problem is located within the boards.txt and you need to find the correct fuse settings for your Mini.
check your boards.txt against this one:


and maybe you find the missing bits.