Author Options:

Can you help diagnose my Seal-A-Meal? Answered

I have a Seal-A-Meal brand vacuum sealer, that all of a sudden stopped working properly. It has no On-Off switch. You simply plug it in, and then put the bag up to the vacuum area and then press down and hold the lid when its vacuuming the air out and then seals the bag closed.

When it stopped working, a vacuum bag was placed (as we normally would) and then the lid was put down and pressed. The motor is still running, but normally it makes a louder noise as its vacuuming the air out, and this time it didn't work. (No vacuum). Since it wouldn't vacuum the air, it then wouldn't also seal the bag.

Oddly, when I remove the bag and close it (with nothing in there) it DOES make the high pitched-noise, the green light comes on (hands free) and then does the sealing, even though there is nothing to seal.  But when I put the bag in - nothing but the motor running consistently with no change in intonation of the motor and the green light doesn't come on and it doesn't seal.

So with the bag - not working.  Without the bag, it seems to work.

I"m using Food Saver brand bags but those have always worked in the past. 

Any ideas on what to do to service it and hopefully get it working again?


The forums are retiring in 2021 and are now closed for new topics and comments.

3 years ago

I see some people do come here and provide proper info with their request, what a nice change :)
You have a problem with holin or creating the vacuum.
Working without a bag means something is allowing air in when you use a bag.
I simple assume you already tried using just two strips of the bag (open both ends) to check if the unit works then?
If still no go then use asingle strip to check if it creates a vacuum and seals.
All fails could mean your rubber strips pressing on the bag collected dirt underneath or went a bit hard.
Pull them out, clean the plastic groove they were in and for the rubber itself:
Soak in warm soapy water, clean properly and before putting back in eat them up in almost boiling water (dry right after).
This gives them more softness and makes a good install much easier.
While you do all this take a flashlght or use direct sunlight to check for tiny cracks in the pastic that is part of your sealing chamber - sometimes plastic goes brittle and tiny crack can be enough under pressure to suck in unwanted air.
Don't want to hear that still nothing works when you are done with all that ;)

Ok, still no good?
Do the full manual check:
As you have no seperate switch you might have to open the unit and add some wires to join the original switch - it should be somewhere in the hinge area.
A simple (mains power rated) push button or light switch will do you fine.
When activated the pump will start so check what happens if you close the hole in the sealing chamber that suck the air in.
Unit not building vacuum and starting the sealing quickly meas a leak in the line to the pump or a failing pump (might only need a service and lube).
Working fine in this stage only leaves your vacuum chamber ans rubber seals to let unwanted air get in.
Well, that is if your bad is not leaking ;)
The rubber can be replaced but if you can't find original then silicone tubing works great too in the right diameter for your grooves of course.
Don't forget to seal the ends with silicone chaulk before use though ;)


Reply 1 year ago

Ok so this is my first time using this and I'm assuming the roll of bags that come with this sealer are the proper bags. Now, I've cut the bag with the bag zipper cutter that's built in to this machine. With that being said I dont have a sealed end or a one layer piece.
I did try sealing just the smooth non-bubbled side of the bag and the sealers lights FINALLY come on. I waited. Said it was sealing and I stoped the process. Why can't I get that process to work to seal an end of my bag so I can place my big fat 20 dollar steak and seal this beoch up lol. I'm kinda on a time limit for I have a 9 HR Dr ahead of me.