Author Options:

Combat arms; Failed to join battle, connection timed out? Answered

OK, so i downloaded Combat Arms to see what it was like, i downloaded it, installed it, made a user. then when i started it, it worked fine, i logged in, joined a server and a room, then it said the game was starting so i waited, it counted down 5, 4, 3, 2, 1 then the game froze for around 5 seconds, I thought the game was starting so I waited. Then a message popped up: Failed to join battle. Connection timed out?
I have tried re-installing the game twice, allowed CA through my firewall and anti virus (AVG 2011) and yet it still wouldn't let me join a game. I then disabled my firewall and AVG to see if it still happened, STILL DIDN'T WORK! by this point I was getting annoyed :S
I exited CA and re-enabled both my firewall and AV software. any help would be appreciated, thanks in advance.
P.S. We recently got a new router so it's not our internet, i am also running windows 7 64bit, running CA in admin and compatibility for xp sp2
thanks in advance :D


The forums are retiring in 2021 and are now closed for new topics and comments.

10 years ago

We recently got a new router so it's not our internet,
How does that logic work?  There's more to the internet than routers y'know.

You say it reports "Connection timed out", that's a connectivity problem so messing with the firewall and anti virus was a good idea (re-installing the game twice was not).

Is this a legitimate and in no way dodgy version of CA?

I'd pick through these and see if you can find anything that matches your problem: