Author Options:

ERROR 500: java.lang.RuntimeException:(what is this?) Answered

Im not sure if this belongs here but when i tried to delete a comment it said
ERROR 500: java.lang.RuntimeException: none of the thingId values was set, don't know what to add the comment TO


java.lang.RuntimeException: none of the thingId values was set, don't know what to add the comment TO
at com.instructables.webapp.comment.CommentForm.load(CommentForm.java:148)
at com.instructables.servlet.ActionServlet.fillFormBean(ActionServlet.java:282)
at com.instructables.servlet.ActionServlet.process(ActionServlet.java:270)
at com.instructables.servlet.ActionServlet.doPost(ActionServlet.java:137)
at com.instructables.webapp.edit.EditServlet.doPost(EditServlet.java:201)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:154)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:92)
at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:106)
at com.instructables.filter.SecurityFilter.doFilter(SecurityFilter.java:164)
at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
at com.instructables.filter.HibernateSessionRequestFilter.doFilter(HibernateSessionRequestFilter.java:70)
at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:173)
at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229)
at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:274)
at com.caucho.server.port.TcpConnection.run(TcpConnection.java:511)
at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:520)
at com.caucho.util.ThreadPool.run(ThreadPool.java:442)
at java.lang.Thread.run(Thread.java:619)

what is going on?
and i'm sorry if i shouldn't have created this topic


The forums are retiring in 2021 and are now closed for new topics and comments.

12 years ago

I tried it and it worked ,thanks!


12 years ago

Nothing to be sorry about -- you created this topic in the Bugs Forum, which is exactly the right place :-)

I have gotten the error above several times, and I think I've figured it out. The bottom line, for you, is this

If you want to delete a comment you just created, reload the page first.

There is some "state information" that gets saved when you load a page with comments, but which is not updated after you create a new comment yourself. You need to reload/refresh the page (even though you can see your comment :-), then you can delete your comment successfully and move forward.