1387Views9Replies

Author Options:

ERROR 500: javax.servlet.jsp.JspException Answered

Win XP_pro, browser FF 3.6.8  in any instructables page get error message:

ERROR 500: javax.servlet.jsp.JspException: ServletException in '/common/newlayout.jspx': Can't insert page '/pages/explore/type/instructable_body.jsp' : ISO-8859-10 Exception javax.servlet.jsp.JspException: ServletException in '/common/newlayout.jspx': Can't insert page '/pages/explore/type/instructable_body.jsp' : ISO-8859-10 at org.apache.tiles.taglib.InsertTag$InsertHandler.doEndTag(InsertTag.java:923) at org.apache.tiles.taglib.InsertTag.doEndTag(InsertTag.java:457) at _jsp._pages._explore._type._instructable__jsp._jspService(_instructable__jsp.java:424) at com.caucho.jsp.JavaPage.service(JavaPage.java:60) at com.caucho.jsp.Page.pageservice(Page.java:570) at com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:179) at com.caucho.server.webapp.DispatchFilterChain.doFilter(DispatchFilterChain.java:115) at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229) at com.caucho.server.webapp.RequestDispatcherImpl.include(RequestDispatcherImpl.java:485) at com.caucho.server.webapp.RequestDispatcherImpl.include(RequestDispatcherImpl.java:350) at com.instructables.servlet.ActionServlet.sendToJspPage(ActionServlet.java:278) at com.instructables.servlet.ActionServlet.doGet(ActionServlet.java:87) at javax.servlet.http.HttpServlet.service(HttpServlet.java:115) at javax.servlet.http.HttpServlet.service(HttpServlet.java:92) at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:106) at com.caucho.filters.GzipFilter.doFilter(GzipFilter.java:208) at com.instructables.filter.FilterWrapperFilter.doFilter(FilterWrapperFilter.java:47) at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70) at com.instructables.filter.HibernateSessionRequestFilter.doFilter(HibernateSessionRequestFilter.java:48) at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70) at com.instructables.filter.TemporaryProFilter.doFilter(TemporaryProFilter.java:77) at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70) at com.instructables.filter.SecurityFilter.doFilter(SecurityFilter.java:140) at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70) at com.instructables.filter.SetupFilter.doFilter(SetupFilter.java:68) at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70) at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:173) at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229) at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:274) at com.caucho.server.port.TcpConnection.run(TcpConnection.java:514) at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:527) at com.caucho.util.ThreadPool.run(ThreadPool.java:449) at java.lang.Thread.run(Thread.java:595) Caused by: javax.servlet.ServletException: javax.servlet.jsp.JspException: Can't insert page '/pages/explore/type/instructable_body.jsp' : ISO-8859-10 at com.caucho.jsp.PageContextImpl.handlePageException(PageContextImpl.java:1120) at _jsp._common._newlayout__jspx._jspService(_newlayout__jspx.java:431) at com.caucho.jsp.JavaPage.service(JavaPage.java:60) at com.caucho.jsp.Page.pageservice(Page.java:570) at com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:179) at com.caucho.server.webapp.DispatchFilterChain.doFilter(DispatchFilterChain.java:115) at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229) at com.caucho.server.webapp.RequestDispatcherImpl.include(RequestDispatcherImpl.java:485) at com.caucho.server.webapp.RequestDispatcherImpl.include(RequestDispatcherImpl.java:350) at com.caucho.jsp.PageContextImpl.include(PageContextImpl.java:933) at com.caucho.jsp.PageContextImpl.include(PageContextImpl.java:870) at org.apache.tiles.TilesUtilImpl.doInclude(TilesUtilImpl.java:143) at org.apache.tiles.TilesUtil.doInclude(TilesUtil.java:149) at org.apache.tiles.taglib.InsertTag.doInclude(InsertTag.java:760) at org.apache.tiles.taglib.InsertTag$InsertHandler.doEndTag(InsertTag.java:892) ... 32 more Caused by: javax.servlet.jsp.JspException: Can't insert page '/pages/explore/type/instructable_body.jsp' : ISO-8859-10 at org.apache.tiles.taglib.InsertTag$InsertHandler.doEndTag(InsertTag.java:898) at org.apache.tiles.taglib.InsertTag.doEndTag(InsertTag.java:457) at _jsp._common._newlayout__jspx._jspService(_newlayout__jspx.java:370) ... 45 more

Discussions

The forums are retiring in 2021 and are now closed for new topics and comments.
0
kelseymh
kelseymh

10 years ago

A workaround has been reported for this error: set "en-us" as the first language in your preferences.

0
rachel
rachel

10 years ago

Hi, this has only shown up previously for people whose browsers are set to default to a Baltic language like Lithuanian or Latvian. Is this the case for those of you seeing the error? If so, does it go away if you set your browser's default language to English (this is usually in the Preferences or Options dialog, depending on which browser and OS you use)?

0
zetas
zetas

Reply 10 years ago

Yes, it helped. But before everything worked well, until the renewal of Instructables page.

0
StumpChunkman
StumpChunkman

10 years ago

Is this on the homepage, or a specific instructable/submit/forum/other page?

0
zetas
zetas

Reply 10 years ago

Homepage (and forum) work great, but if I click on any instructables, I got error message.

0
zetas
zetas

Reply 10 years ago

Any solutions?

0
Nissan_350z
Nissan_350z

10 years ago

And I have this problem. Home Page working great, but if I open any instructables I get the same error.

0
Kryptonite
Kryptonite

10 years ago

Christ, that's a big java bug. Actually, it's probably just small! Don't you love code?

0
ikkajh
ikkajh

10 years ago

I have the same problem!! I'm using windows 7 and all browsers (IE, Firefox and Opera) has same problem to open instructables. Homepage and forum are working fine only instructables aren't working. This error only appears when I'm logged in.