4Views0Replies

Author Options:

ESP-12E NodeMCU trouble? Answered

First, thank you so much for making this class! It's exactly what I was looking for. I'm using an ESP-12E NodeMCU, and the previous lessons went just peachy. I made the changes you suggested (using the different IO pins) for the button press sketch, and that worked great. For the WiFi client Basic sketch, my board established the connection with no problems. I did a big happy dance and everything. I've hit a bit of a wall, though. I'm having trouble in this lesson connecting to Adafruit.
Here's what I've tried so far:
I double-checked the sketch and wiring to make sure my digital pins were changed correctly for the NodeMCU board and that the sketch matches my wiring. I double and triple checked the Adafruit login info and feed name in the sketch. I tried regenerating a new key and updated the sketch to include the new key. I followed the Adafruit troubleshooting guide and changed the line in the sketch from Serial.println(.); to Serial.println(io.statusText());. This helped me verify that my board is still connecting to the internet, but that it's not connecting with Adafruit. The message "Disconnected from Adafruit IO" prints endlessly in the serial monitor.
So, after looking through some forums on the subject, it sounded like maybe I needed to flash the firmware on my board. I followed this Instructables tutorial (https://www.instructables.com/id/How-to-Flash-NodeMCU-Firmware-in-ESP8266/) to flash the firmware (it was at this point that I felt simultaneously like I was in way over my head and like I needed to update my LinkedIn profile to say "super hacker". That's a very complex emotion). The only modules I added with the defaults in the Build Files step were the MQTT and Wifi monitor modules. Maybe I need to add some others? The file builder sent me two files, a float file and an integer file. Does it matter which one I use to flash? Is flash even a verb in this context? I'd never heard of a breadboard or Arduino or written a code until I stumbled into this amazing world of making in December of last year, so some of this feels like drinking from an open fire hydrant.
Anyway, nothing changed. The previous lessons' sketches still work great, and this one still gets me a "disconnected from Adafruit IO" message. Sorry this turned into a novel. I just didn't want you to think I hadn't tried anything yet.

TL;DR ---
I love your class and I'm binge-watching your tutorials like a Netflix series. I can't figure this lesson out, though. The sketch results in a message on the serial monitor repeatedly saying "Disconnected from Adafruit IO". Thanks so much for your time!

Discussions