79Views6Replies

Author Options:

Fluctuating voltage? Answered

I am trying to build an ammeter using a 100:5A CT and a pic16F716 and display the value using 7segments. However, The voltage I get from the CT after rectifying it using an OPAMP still fluctuates between 4.8 and 5.4 .  I don't understand what is causing it to fluctuate that way. I will attach a picture of the circuit I am working on.

Discussions

0
None
steveastrouk

3 years ago

A very nicely developed circuit Indira, you've really listened to what people have suggested, which is pleasing to see.

I suggest you have some other source of noise. Have you got an oscilloscope to look at the output on C2 in your diagram ?

0
None
IndiraK2steveastrouk

Answer 3 years ago

I added a simulation using the oscilloscope. The yellow represents the input current while the blue almost straight line is the output from C2.

Oscillo.PNG
0
None
steveastroukIndiraK2

Answer 3 years ago

Have you built this, or are you working purely in a simulation. The blue trace of the final signal looks beautiful, and what you should expect.

0
None
IndiraK2steveastrouk

Answer 3 years ago

I have built it and actually testing how it works. However coding has never been my forte so I tried using parsic to create the code. Still the last 7 segment doesn't light up.

0
None
steveastroukIndiraK2

Answer 3 years ago

Get it to output the measured current to the serial port first, before you worry about the display. Lets see if the real data is noisy.