Author Options:

Getting my comp to see my arduino uno clone ? The same ol windows route shown everywhere aint werkin'!!? Answered

XP pro -sp3 -  ...I've tried installing the official USB2.0 driver, I've  tried the Virtual com port and the FTDI  drivers from the official sites...NOTHIN'!!

I keep getting FOUND NEW HARDWARE -USB2.0-SERIAL...I go through all the steps found everywhere on how to "normally" get the comp and UNO to show up in sys' properties and hardware profiles etc etc....problem is I dont get any of the results nor devices these how-tos are showing. I know my way around a comp and windows...I'm just not getting past the NEW HARDWARE USB2.0  issue..let alone even seeing UNO as a device. The virtual port drivers dont do anything at all...no more ports show up, no option to create one....

I've installed the arduino drivers incl. USB and the UNO drivers...no love either
I've uninstalled and installed in the root dir. ..no luck..
I even changed the ATmega from the 8A it came with to a ATm328 w/ bootloader and blink sketch already installed on  my Arduino as well.

ANYONE have this issue that has found a solution?.... other than throwing my comp out the window and using the UNOs as fancy paper weights?


The forums are retiring in 2021 and are now closed for new topics and comments.

6 years ago

A very simple solution (after a lot of search in the internet):

arduino clone might use a CH340/CH341 USB to serial communication chip.
That is the component which your computer needs the driver for. Just
use that CH341 driver (http://wch-ic.com/download/list.asp?id=127)
instead of the driver that comes with the arduino software.

That worked for my 3€ china clone like a charm.