625Views20Replies

Author Options:

Google search not working Answered

Google Search is not working today ???

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
0
rachel
rachel

10 years ago

Everyone, thanks for this debugging help. May I ask you to post the specific search terms you used that weren't working? The HTML source posted by kelseymh makes me think the issue might be related to the instructables (or forum topics, etc) being returned from the search, rather than the browser.

0
kelseymh
kelseymh

Reply 10 years ago

Sigh. As of this morning, the searches I had used which produced failures are working just fine:
bugs
bug reports
sliders
sliders inurl:Accessibility
Either everything is back to normal (did you roll out some unrelated bug fix?), or it was intermittent, and therefore hard to troubleshoot.

0
Wehrdo
Wehrdo

10 years ago

Search isn't working for me either. Mac OS X 10.6.4, Firefox 3.6.3 or Safari 5.0.3.

0
NachoMahma
NachoMahma

10 years ago

. Works for me. WinXP SP3 & FF3.6.15

0
kelseymh
kelseymh

Reply 10 years ago

Could you (or Kiteman) do a "view source" and see if the "HTML" (it isn't really) looks the same as what I posted?

0
NachoMahma
NachoMahma

Reply 10 years ago

. I get what appears to be a well-formed page (first few lines below). A search for "tiles" comes up MT.



<!DOCTYPE html SYSTEM "about:legacy-compat">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml">
<head>
<title>Search Instructables</title>
<style type="text/css" media="all">
@import url( "/static/css/instructables.css?" );
@import url( "/static/css/instructabot.css?" );
...

0
kelseymh
kelseymh

Reply 10 years ago

Yep, so do I, now.

0
StumpChunkman
StumpChunkman

Reply 10 years ago

You might have seen something weird if you were trying to get source code when Rachel was updating the website. Yeah?

0
kelseymh
kelseymh

Reply 10 years ago

See below. Was that at 11:30 this morning?

0
StumpChunkman
StumpChunkman

Reply 10 years ago

She emailed that she pushed a fix for an issue that came up at 1220...depending on how long it took, and how log she waited after it finished...it could easily have been around then.

0
Lithium Rain
Lithium Rain

Reply 10 years ago

I am having this problem now. Search results show nothing but a blank page where hits should be. :(

0
StumpChunkman
StumpChunkman

Reply 10 years ago

Yeah, I just did some more checking with Firefox, and while certain things return the normal set of results, other search queries were blank. I tried the same searches in Chromium at it seemed to work fine. I passed the information on to the Dev Team, hopefully they'll have some time soon.

0
Lithium Rain
Lithium Rain

10 years ago

Ubuntu Linux running both Chromium 10.0.648.127 and Firefox 3.6.15 here - no such bug.

0
kelseymh
kelseymh

10 years ago

Well, it seems to be working again, at least for me (FF on Mac).

0
kelseymh
kelseymh

10 years ago

I confirm this -- I'm using Firefox 3.6.15 under MacOSX 10.5.8. The search box generates an appropriate URL, but the display is completely empty. The HTML source being returned is:

<tiles:insert xmlns:tiles="http://struts.apache.org/tags-tiles"
definition=".search"><tiles:put name="title" value="Search
Instructables" /><tiles:put name="titlebar" value="/common
/null.html" /><tiles:put name="body" value="/pages/search
/search_body.jsp" /></tiles:insert>
0
Kiteman
Kiteman

Reply 10 years ago

I wonder if it's a Mac-only bug?

I'm using the same version of FF, in XP, and it's fine.

0
Kiteman
Kiteman

10 years ago

As of this time-stamp, the search is working.

If it still isn't working for you, could you add a few details, such as your OS & browser?

0
jpayton
jpayton

10 years ago

I noticed this too. Only source code that loads is: