Author Options:

Having a peculiar issue with the max6675 and grounds? Answered

So first off, this is an application for use in a car. I have ensured that all of my grounds are good, and the power is clean, so I know these are not the issue, at least not on the car side of things.

I am trying to get an electric fan controlled by an atmega328 (through a relay), which I have successfully achieved  on bench tests using an alternative heat source. It works reliably until I apply the circuit in the car. When I install it in the car with my thermocouple on the radiator pipe for the temperature reference I get all sorts of temperatures that are not the correct one. Its either very high, or very low. I have tried multiple thermocouples (of similar style) with no changes. If my thermocouple is not making contact with any grounded portion of the car (for example, the engine) it reads fine, so I know that my issue lies somewhere in there. An easy solution would be to simply mount the sensor in a coupler in the radiator hose (thus isolating it as best as I can) but I would rather fix the issue than apply a bandaid. I've tried searching for other people having a similar issue but haven't had any luck.

One peculiar thing to note is that if I have the ground disconnected, and the thermocouple touching a ground, the system receives power, so I am assuming that the junction makes contact with the outer case of the thermocouple.

My circuit is nothing too elaborate (I can upload a schematic if need be); I have a DC/DC adjustable converter to get 5v for the micro and 6675 power, which does not have an isolated ground, an atmega328, an OLED display, some tact buttons, and a max6675 development board. There are other passives as well but those should be minor.

Does anyone have any idea what may be going on with this? I'm stumped. I should be able to provide any info you may need. 

PS: this is the development board and thermocouple that I am using:



3 years ago

Maxim's own app circuit shows one side of the junction actually grounded.


3 years ago

You have a ground loop problem. Insulate the probe or attach it to a non conductive portion of the system like you mentioned with the radiator hose.


3 years ago

I have several thermocouples here - none has a connection from the casing to the testing leads.
From the images it seems yours is the same as mine, so if you get a problem with the probe touching ground I assume it is a matter if RF.
If the car produces some RF on the ground (spark plugs, alternator...) then this signal can be transfered to the probe leads as they act like an antenna.
But there should be no electrical connection between the probe leads and shielding/case to start with.
Unless you want to try a different thermocouple you test this:
Connect the shielding of the thermocouple to the negative of your arduino and the sensor board - connect this now nommon negative with the ground of the car.

Still I suspect a faulty sensor, so if you can measure if there is any connection between the probes and the shielding.