260Views9Replies

Author Options:

Image annotations running off of image, not displaying Answered

Image annotations are being lost either by being below or beyond the edge if the image they relate to. This has only happened since the new image display system was implemented.

The old image system allowed annotations to run below and of the side of an image, where as the new one crops the text to fit only over the image.

The old image annotation system also wrapped the text after a number of characters, where as the new system allows text to run on indefinably  Users can manually insert line breaks in the annotations with the new system (not possible with the old system), however for old instructables this introduces the problem of annotations running off the image and being unreadable.

This appears to be on every instructable, providing there are annotations on the images, and the annotations are long enough, or positioned such that they run past the edge, or bottom of the image.
An example of this is: https://www.instructables.com/id/Cat-enclosure-with-high-cat-walktunnel-utilizes-/
On this instructable there are examples of both running of the edge of an image, and falling off the bottom. It also shows an exception to the problem, the first image allows the annotation to go beyond the boundary of the image, but all subsequent images have the issue.

Discussions

0
None
Kiteman

7 years ago

When you click on the image, and get the slide-show version, they display correctly, but you're right, this shouldn't be happening either.

Bug report submitted.

0
None
makendoKiteman

Reply 7 years ago

I'm guessing this is still broken? Latest Chrome, XP & 7 still seems to have this problem...

0
None
Kitemanmakendo

Reply 7 years ago

But, if you actually click on the photo, is it fine?

0
None
makendoKiteman

Reply 7 years ago

Yep, the image notes function correctly in the pop-up image viewer.
When in the main body, they're also broken in Safari (ios6).

0
None
Kitemanmakendo

Reply 7 years ago

I think that's it is not broken, rather, it was made incorrectly in the first place.

0
None
makendoKiteman

Reply 7 years ago

I seem to remember image notes once working just fine; I think this happened after the last big update.