388Views22Replies

Author Options:

I've got an IRQ problem, help please? Answered


My DVD drive won't work due to an IRQ conflict, but I can't manually re-assign the IRQ.
It's XP, and it occurred after replacing the mainboard. (The option is "grayed-out")

L


Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
0
NachoMahma
NachoMahma

10 years ago

. If steveastrouk's suggestion of deleting the device (see Device Manager) and forcing XP to try again doesn't work, I'd try poking around in the BIOS.
.  Might be worthwhile to double-check HDD/CD/DVD jumper setting. I recommend cable select (CS) for all (E)IDE devices unless you have a reason to do otherwise.

0
lemonie
lemonie

Answer 10 years ago


Oh yes (tone of derision), I'll let you know, but I think you're guessing. (it is a Windows IRQ conflict)

L

0
NachoMahma
NachoMahma

Answer 10 years ago

.  Yep, I'm guessing, but it has been many years (at least 20) since I have run into an IRQ problem. Used to be quite common back in the Good Ol' Days of '286 processors and DOS, but I can't even remember what we did to straighten it out. I think we changed jumpers on cards, but that may be an overactive imagination.

0
lemonie
lemonie

Answer 10 years ago


Ditto, man you think these things will do it right on auto' these days...

L

0
frollard
frollard

Answer 10 years ago

IRQ is a bios setting...as I recall you don't change it after boot time -- thats why windows can't change it. Bios is causing the conflict.

0
lemonie
lemonie

Answer 10 years ago


I don't seem to have that option (I did look). The mainboard manual is on a CD... I'll try that line of enquiry though.

L

0
frollard
frollard

Answer 10 years ago

Other thought -- I've not seen a mobo support manually assigning irq since about the year 2000.

0
seandogue
seandogue

10 years ago

You *may be able to alter the IRQ map within the bios. I'm not sure otherwise. Most devices are automatic these days

0
lemonie
lemonie

Answer 10 years ago


No, looked there.

L

0
Kryptonite
Kryptonite

10 years ago

I thought it said IQ for a second... I think I ought to get mine checked.

0
Re-design
Re-design

10 years ago

Find out what other function is using irq 14 and try disabling or reloading that. My primary IDE irq is 14 so I feel that that is correct.

0
lemonie
lemonie

Answer 10 years ago


It's a PCI to PCI thing, I didn't think that's a good idea because it's probably in use.

L

0
Re-design
Re-design

Answer 10 years ago

Is this a laptop or a desktop unit? I think you need to reload your system drivers. Especially since you said you just replaced the motherboard.

I've looked at 6 computers of mine and they all show irq 14 for the primary ide channel.

0
lemonie
lemonie

Answer 10 years ago


I can't reload them because they're on the CD (yes I did look online)
Desktop.

L

0
Re-design
Re-design

Answer 10 years ago

You can delete the offending one and then it will free up the irq 14 and your cd will run.

0
lemonie
lemonie

Answer 10 years ago


I will try deleting things.

L

0
Re-design
Re-design

Answer 10 years ago

googling "irq 14" gets info that it is almost univerally dedicated to the primary ide so when the pci to pci... took it over it is surely a mistake.

0
steveastrouk
steveastrouk

10 years ago

Delete the device and let it try again ?

0
lemonie
lemonie

Answer 10 years ago

I tried that (disable) but I'l have a look at delete, and I disabled the floppy-controller (Jees-us that still was there even though I've not used a floppy for at least 10 years..) That's IRQ 6 free, but no joy...
Why is it grayed?

L

0
steveastrouk
steveastrouk

Answer 10 years ago

Disable will retain the old settings, but not use them, delete will deallocate the settings, and scan for new hardware should reallocate them in the right place. There IS still the hammer.... Steve

0
kelseymh
kelseymh

10 years ago

If the machine still functions after hammering, you could reformat the drive and install Ubuntu.

0
steveastrouk
steveastrouk

10 years ago

....and if Nacho's suggestion doesn't work, hit it with big hammers. ......